Search: Home Bugtraq Vulnerabilities Mailing Lists Jobs Tools Beta Programs

mod_php php
200301-8
Published: 2003-01-13 15:00:13
Updated: 2003-01-13 15:00:13

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

- - --------------------------------------------------------------------
GENTOO LINUX SECURITY ANNOUNCEMENT 200301-8
- - --------------------------------------------------------------------

PACKAGE : mod_php php
SUMMARY : buffer overflow
DATE    : 2003-01-13 15:01 UTC
EXPLOIT : remote

- - --------------------------------------------------------------------

- From advisory:

"If you use the wordwrap() function on user-supplied input, a 
specially-crafted input can overflow the allocated buffer and 
overwrite the heap.  Exploit looks very difficult, but still 
theoretically possible."

Read the full advisory at
http://marc.theaimsgroup.com/?l=bugtraq&m=104102689503192&w=2

SOLUTION

It is recommended that all Gentoo Linux users who are running
dev-php/php-4.2.3 and/or dev-php/mod_php-4.2.3  or earlier update 
their systems as follows:

emerge rsync
emerge php

and/or

emerge mod_php

finish with:

emerge clean

- - --------------------------------------------------------------------
aliz@gentoo.org - GnuPG key is available at www.gentoo.org/~aliz
rphillips@gentoo.org
- - --------------------------------------------------------------------
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.1 (GNU/Linux)

iD8DBQE+ItSXfT7nyhUpoZMRAkmYAKCU00hustnHo69YNYw0IwNezKQN7wCfWs9r
UPRKjcVEmXPuN6zq7wjSLYc=
=0qtv
-----END PGP SIGNATURE-----







 

Privacy Statement
Copyright 2008, SecurityFocus