BugTraq
MDKSA-2005:148 - Updated vim packages fix vulnerability Aug 23 2005 12:49AM
Mandriva Security Team (security mandriva com)
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

_______________________________________________________________________

Mandriva Linux Security Update Advisory
_______________________________________________________________________

Package name: vim
Advisory ID: MDKSA-2005:148
Date: August 22nd, 2005

Affected versions: 10.0, 10.1, 10.2, Corporate 3.0,
Corporate Server 2.1,
Multi Network Firewall 2.0
______________________________________________________________________

Problem Description:

A vulnerability was discovered in the way that vim processed modelines.
If a user with modelines enabled opened a textfile with a specially
crafted modeline, arbitrary commands could be executed.
_______________________________________________________________________

References:

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2005-2368
______________________________________________________________________

Updated Packages:

Mandrakelinux 10.0:
962c81613136ed7ca634b960a92722b4 10.0/RPMS/vim-X11-6.2-14.4.100mdk.i586.rpm
cd0286f3cdcca0bcb61e91b690c33e50 10.0/RPMS/vim-common-6.2-14.4.100mdk.i586.rpm
84c7a8451f4b84ae5f362ad1e21fff66 10.0/RPMS/vim-enhanced-6.2-14.4.100mdk.i586.rpm
669fc75bbda5aa9fb66f63428ba340e5 10.0/RPMS/vim-minimal-6.2-14.4.100mdk.i586.rpm
0c122671de7f0be1fe5889b97077ae4d 10.0/SRPMS/vim-6.2-14.4.100mdk.src.rpm

Mandrakelinux 10.0/AMD64:
0f3caed96b7f1f2baed8a8962ec3b4ca amd64/10.0/RPMS/vim-X11-6.2-14.4.100mdk.amd64.rpm
ab87468b1829e910b4ca7ac0d0100978 amd64/10.0/RPMS/vim-common-6.2-14.4.100mdk.amd64.rpm
ffd161316881f3b1507eb3290094a25a amd64/10.0/RPMS/vim-enhanced-6.2-14.4.100mdk.amd64.rpm
4868d574f0f9f25e758f925083a90b72 amd64/10.0/RPMS/vim-minimal-6.2-14.4.100mdk.amd64.rpm
0c122671de7f0be1fe5889b97077ae4d amd64/10.0/SRPMS/vim-6.2-14.4.100mdk.src.rpm

Mandrakelinux 10.1:
aafd1a6fd9f2b5971a563f4e2afa962a 10.1/RPMS/vim-X11-6.3-5.4.101mdk.i586.rpm
376493f4f15bf4472e5b9607d3274231 10.1/RPMS/vim-common-6.3-5.4.101mdk.i586.rpm
9939e76b7510a330f999a0c59a8fe7eb 10.1/RPMS/vim-enhanced-6.3-5.4.101mdk.i586.rpm
766aee98f2396becd720b924512bcd16 10.1/RPMS/vim-minimal-6.3-5.4.101mdk.i586.rpm
f373a2117c65bf18d25efd95db9fc3cd 10.1/SRPMS/vim-6.3-5.4.101mdk.src.rpm

Mandrakelinux 10.1/X86_64:
57b16ed9c7ec73a21849f813b7d14c8d x86_64/10.1/RPMS/vim-X11-6.3-5.4.101mdk.x86_64.rpm
7a7d30797acda07ae1ff25d6f7c58dca x86_64/10.1/RPMS/vim-common-6.3-5.4.101mdk.x86_64.rpm
65e69d9cb477cc0477d3ddf9687065d4 x86_64/10.1/RPMS/vim-enhanced-6.3-5.4.101mdk.x86_64.rpm
1807eb9791da5518167a3fc2f4637776 x86_64/10.1/RPMS/vim-minimal-6.3-5.4.101mdk.x86_64.rpm
f373a2117c65bf18d25efd95db9fc3cd x86_64/10.1/SRPMS/vim-6.3-5.4.101mdk.src.rpm

Mandrakelinux 10.2:
534262aacc55523ac8f70bd0bb128c0d 10.2/RPMS/vim-X11-6.3-12.1.102mdk.i586.rpm
edc277a6b8e1f68f936283addd4c693b 10.2/RPMS/vim-common-6.3-12.1.102mdk.i586.rpm
ca29f9b56afb7130378179187e2dff48 10.2/RPMS/vim-enhanced-6.3-12.1.102mdk.i586.rpm
890cee90f519765234316fe31e53adab 10.2/RPMS/vim-minimal-6.3-12.1.102mdk.i586.rpm
91627d558879abb42b848dfba98f2c75 10.2/SRPMS/vim-6.3-12.1.102mdk.src.rpm

Mandrakelinux 10.2/X86_64:
1df911cedfaedfe99e60463296af6672 x86_64/10.2/RPMS/vim-X11-6.3-12.1.102mdk.x86_64.rpm
8a673c26fac6a9ab7d06d5295b4c7229 x86_64/10.2/RPMS/vim-common-6.3-12.1.102mdk.x86_64.rpm
b4bc9aec773899cfee039cc7a3eacb8a x86_64/10.2/RPMS/vim-enhanced-6.3-12.1.102mdk.x86_64.rpm
a5c194fb681f9eb51c6b2dae3c47d716 x86_64/10.2/RPMS/vim-minimal-6.3-12.1.102mdk.x86_64.rpm
91627d558879abb42b848dfba98f2c75 x86_64/10.2/SRPMS/vim-6.3-12.1.102mdk.src.rpm

Multi Network Firewall 2.0:
a155774dfb2e3de1398520b1fcc26ec7 mnf/2.0/RPMS/vim-common-6.2-14.4.M20mdk.i586.rpm
568587310ed3f7901dd5d4b5a165f32f mnf/2.0/RPMS/vim-enhanced-6.2-14.4.M20mdk.i586.rpm
b677a06a11ed028b08d8eeed9bcaaab6 mnf/2.0/RPMS/vim-minimal-6.2-14.4.M20mdk.i586.rpm
6bd495589bc061390b3bf2bfa1470c0a mnf/2.0/SRPMS/vim-6.2-14.4.M20mdk.src.rpm

Corporate Server 2.1:
5a0b82ffacb2846807366ed0df79aa5f corporate/2.1/RPMS/vim-X11-6.1-34.5.C21mdk.i586.rpm
e3645b75141486cd7a0df56f1a55b21f corporate/2.1/RPMS/vim-common-6.1-34.5.C21mdk.i586.rpm
20d0a95ab5a8deadbb0e776997f436fb corporate/2.1/RPMS/vim-enhanced-6.1-34.5.C21mdk.i586.rpm
6de52fca478c565cded946eb24d7fbe8 corporate/2.1/RPMS/vim-minimal-6.1-34.5.C21mdk.i586.rpm
944de1a2b8348726c6fbe3bc5c7eb719 corporate/2.1/SRPMS/vim-6.1-34.5.C21mdk.src.rpm

Corporate Server 2.1/X86_64:
c86249e6a7541ef5ddfe2b90e1c498aa x86_64/corporate/2.1/RPMS/vim-X11-6.1-34.5.C21mdk.x86_64.rpm
f21a7e25f753c36c57841e27953e9ed9 x86_64/corporate/2.1/RPMS/vim-common-6.1-34.5.C21mdk.x86_64.rpm
27d5ce793640ae0cfcaebc09a977388d x86_64/corporate/2.1/RPMS/vim-enhanced-6.1-34.5.C21mdk.x86_64.rpm
8e84a6e1153bc4b140916184b5fb2d67 x86_64/corporate/2.1/RPMS/vim-minimal-6.1-34.5.C21mdk.x86_64.rpm
944de1a2b8348726c6fbe3bc5c7eb719 x86_64/corporate/2.1/SRPMS/vim-6.1-34.5.C21mdk.src.rpm

Corporate 3.0:
f9487b4995c1f64b176feec5e93775cb corporate/3.0/RPMS/vim-X11-6.2-14.4.C30mdk.i586.rpm
3d33b7f4c3685c1874b2ca6150b9bf1a corporate/3.0/RPMS/vim-common-6.2-14.4.C30mdk.i586.rpm
9cb2997766630fed03f1da93a874e662 corporate/3.0/RPMS/vim-enhanced-6.2-14.4.C30mdk.i586.rpm
c98990ae777f2d6a16f259412e61b6be corporate/3.0/RPMS/vim-minimal-6.2-14.4.C30mdk.i586.rpm
08174e3db0af720dd3bd8f8ac2492def corporate/3.0/SRPMS/vim-6.2-14.4.C30mdk.src.rpm

Corporate 3.0/X86_64:
52175513104bf687a0dc7002e5d2374f x86_64/corporate/3.0/RPMS/vim-X11-6.2-14.4.C30mdk.x86_64.rpm
719644f6a0b76baa21d0d950b80df548 x86_64/corporate/3.0/RPMS/vim-common-6.2-14.4.C30mdk.x86_64.rpm
c5e65cec1752232eb0123bd5e02970e1 x86_64/corporate/3.0/RPMS/vim-enhanced-6.2-14.4.C30mdk.x86_64.rpm
ef9cdaf59ea64f6abe526c430c368926 x86_64/corporate/3.0/RPMS/vim-minimal-6.2-14.4.C30mdk.x86_64.rpm
08174e3db0af720dd3bd8f8ac2492def x86_64/corporate/3.0/SRPMS/vim-6.2-14.4.C30mdk.src.rpm
_______________________________________________________________________

To upgrade automatically use MandrakeUpdate or urpmi. The verification
of md5 checksums and GPG signatures is performed automatically for you.

All packages are signed by Mandriva for security. You can obtain the
GPG public key of the Mandriva Security Team by executing:

gpg --recv-keys --keyserver pgp.mit.edu 0x22458A98

You can view other update advisories for Mandriva Linux at:

http://www.mandriva.com/security/advisories

If you want to report vulnerabilities, please contact

security_(at)_mandriva.com
_______________________________________________________________________

Type Bits/KeyID Date User ID
pub 1024D/22458A98 2000-07-10 Mandriva Security Team
<security*mandriva.com>

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.4 (GNU/Linux)

iD8DBQFDCnKUmqjQ0CJFipgRAoY4AJwPOXIT8ne8SqI5ZlivuG/6/0MKogCgtRvH
H0rWdeUWG8I62xMkYC4zx4I=
=0T8l
-----END PGP SIGNATURE-----

[ reply ]


 

Privacy Statement
Copyright 2010, SecurityFocus