BugTraq
Multiple Critical and High Vulnerabilities in Oracle Database Server Oct 18 2005 11:13PM
NGSSoftware Insight Security Research (nisr nextgenss com) (1 replies)
David Litchfield of NGSSoftware has discovered discovered multiple critical
and high risk vulnerabilities in the Oracle Database Server. These
vulnerabilities can be exploited by an attacker to gain complete control of
the database server. Versions affected include

Oracle Database 10g - All Releases
Oracle9i Database Server - All Releases

The vulnerabilities include a buffer overflow vulnerability and seventeen
PL/SQL injection vulnerabilities and Oracle has released a patch set to deal
with these issues. It is understood that this patch set fixes a number of
other flaws found by seven other security researchers. Oracle database
administrators are urged to download, test and install the patch set as soon
as possible. See
http://www.oracle.com/technology/deploy/security/pdf/cpuoct2005.html for
more details.

NGSSQuirreL for Oracle, NGSSoftware's advanced vulnerability assessment
scanner and security manager for Oracle, has been updated to check for and
positively identify these flaws in Oracle database servers on the network.
More information about NGSSQuirreL for Oracle can be found at
http://www.ngssoftware.com/squirrelora.htm.

NGSSoftware are going to withhold details about these flaws for three
months. Full details will be published on the 18th of January 2006. This
three month window will allow Oracle database administrators the time needed
to test and apply the patch set before the details are released to the
general public. This reflects NGSSoftware's new approach to responsible
disclosure.

NGSSoftware Insight Security Research
http://www.ngssoftware.com/
+44(0)208 401 0070

[ reply ]
Revision: Multiple Critical and High Vulnerabilities in Oracle Database Server Oct 19 2005 02:06AM
David Litchfield (davidl ngssoftware com)


 

Privacy Statement
Copyright 2010, SecurityFocus