BugTraq
[OpenPKG-SA-2005.023] OpenPKG Security Advisory (openvpn) Nov 02 2005 06:02PM
OpenPKG (openpkg openpkg org)
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

________________________________________________________________________

OpenPKG Security Advisory The OpenPKG Project
http://www.openpkg.org/security.html http://www.openpkg.org
openpkg-security (at) openpkg (dot) org [email concealed] openpkg (at) openpkg (dot) org [email concealed]
OpenPKG-SA-2005.023 02-Nov-2005
________________________________________________________________________

Package: openvpn
Vulnerability: arbitrary code execution, denial of service
OpenPKG Specific: no

Affected Releases: Affected Packages: Corrected Packages:
OpenPKG CURRENT <= openvpn-2.0.2-20050928 >= openvpn-2.0.4-20051102
OpenPKG 2.5 <= openvpn-2.0.2-2.5.0 >= openvpn-2.0.2-2.5.1
OpenPKG 2.4 <= openvpn-2.0-2.4.0 >= openvpn-2.0-2.4.1
OpenPKG 2.3 N.A. N.A.

Dependent Packages: none

Description:
According to a BUGTRAQ report [0], a Denial of Service (DoS)
vulnerability exists in the OpenVPN [1] network security application.
The vulnerability allows a malicious or compromised server to execute
arbitrary code on the client. The Common Vulnerabilities and Exposures
(CVE) project assigned the id CVE-2005-3393 [2] to the problem.

Additionally, another DoS situation can occur if OpenVPN in TCP server
mode receives an error on accept(2) and the resulting exception
handler causes a segmentation fault. The Common Vulnerabilities and
Exposures (CVE) project assigned the id CVE-2005-3409 [3] to the
problem.

Please check whether you are affected by running "<prefix>/bin/openpkg
rpm -q openvpn". If you have the "openvpn" package installed and its
version is affected (see above), we recommend that you immediately
upgrade it (see Solution) [4][5].

Solution:
Select the updated source RPM appropriate for your OpenPKG release
[6][7], fetch it from the OpenPKG FTP service [8][9] or a mirror
location, verify its integrity [10], build a corresponding binary
RPM from it [3] and update your OpenPKG installation by applying the
binary RPM [5]. For the most recent release OpenPKG 2.5, perform the
following operations to permanently fix the security problem (for
other releases adjust accordingly).

$ ftp ftp.openpkg.org
ftp> bin
ftp> cd release/2.5/UPD
ftp> get openvpn-2.0.2-2.5.1.src.rpm
ftp> bye
$ <prefix>/bin/openpkg rpm -v --checksig openvpn-2.0.2-2.5.1.src.rpm
$ <prefix>/bin/openpkg rpm --rebuild openvpn-2.0.2-2.5.1.src.rpm
$ su -
# <prefix>/bin/openpkg rpm -Fvh <prefix>/RPM/PKG/openvpn-2.0.2-2.5.1.*.rpm
________________________________________________________________________

References:
[0] http://marc.theaimsgroup.com/?l=bugtraq&m=113081023121059&w=2
[1] http://www.openvpn.net/
[2] http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-3393
[3] http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-3409
[4] http://www.openpkg.org/tutorial.html#regular-source
[5] http://www.openpkg.org/tutorial.html#regular-binary
[6] ftp://ftp.openpkg.org/release/2.5/UPD/openvpn-2.0.2-2.5.1.src.rpm
[7] ftp://ftp.openpkg.org/release/2.4/UPD/openvpn-2.0-2.4.1.src.rpm
[8] ftp://ftp.openpkg.org/release/2.5/UPD/
[9] ftp://ftp.openpkg.org/release/2.4/UPD/
[10] http://www.openpkg.org/security.html#signature
________________________________________________________________________

For security reasons, this advisory was digitally signed with the
OpenPGP public key "OpenPKG <openpkg (at) openpkg (dot) org [email concealed]>" (ID 63C4CB9F) of the
OpenPKG project which you can retrieve from http://pgp.openpkg.org and
hkp://pgp.openpkg.org. Follow the instructions on http://pgp.openpkg.org/
for details on how to verify the integrity of this advisory.
________________________________________________________________________

-----BEGIN PGP SIGNATURE-----
Comment: OpenPKG <openpkg (at) openpkg (dot) org [email concealed]>

iD8DBQFDaPJPgHWT4GPEy58RAmDqAKCxyFlxNv4WfdCditQrK8+ex6zl+ACeJjki
ussQ4vs+e3IvPJJILk0ubWM=
=Q322
-----END PGP SIGNATURE-----

[ reply ]


 

Privacy Statement
Copyright 2010, SecurityFocus