BugTraq
[ MDKSA-2006:057 ] - Updated cairo packages to address Evolution DoS vulnerability Mar 20 2006 11:17PM
security mandriva com

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

_______________________________________________________________________

Mandriva Linux Security Advisory MDKSA-2006:057
http://www.mandriva.com/security/
_______________________________________________________________________

Package : cairo
Date : March 20, 2006
Affected: 2006.0
_______________________________________________________________________

Problem Description:

GNOME Evolution allows remote attackers to cause a denial of service
(persistent client crash) via an attached text file that contains
"Content-Disposition: inline" in the header, and a very long line in
the body, which causes the client to repeatedly crash until the e-mail
message is manually removed, possibly due to a buffer overflow, as
demonstrated using an XML attachment.

The underlying issue is in libcairo, which is used by recent versions
of Evolution for message rendering.

The Corporate Desktop 3.0 version of Evolution does not use libcairo
and is not vulnerable to this issue.

Updated packages have been patched to correct these issues.
_______________________________________________________________________

References:

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-0528
_______________________________________________________________________

Updated Packages:

Mandriva Linux 2006.0:
18795da3000ba593f1667b14c299a505 2006.0/RPMS/libcairo2-1.0.0-8.1.20060mdk.i586.rpm
8cc112928efae0689998f9eeab317e16 2006.0/RPMS/libcairo2-devel-1.0.0-8.1.20060mdk.i586.rpm
38abc115e3d581fed3788a543d54acea 2006.0/RPMS/libcairo2-static-devel-1.0.0-8.1.20060mdk.i586.rpm
d611cf94f1bee1c88810053cc6dce68c 2006.0/SRPMS/cairo-1.0.0-8.1.20060mdk.src.rpm

Mandriva Linux 2006.0/X86_64:
8b134af67bed9ea300530e02765d34bb x86_64/2006.0/RPMS/lib64cairo2-1.0.0-8.1.20060mdk.x86_64.rpm
e3626b3500ab87dc9abd0ef05d8b1870 x86_64/2006.0/RPMS/lib64cairo2-devel-1.0.0-8.1.20060mdk.x86_64.rpm
ce16dbfb1065b07c758ff5afb5e89dca x86_64/2006.0/RPMS/lib64cairo2-static-devel-1.0.0-8.1.20060mdk.x86_64.rp
m
d611cf94f1bee1c88810053cc6dce68c x86_64/2006.0/SRPMS/cairo-1.0.0-8.1.20060mdk.src.rpm
_______________________________________________________________________

To upgrade automatically use MandrivaUpdate or urpmi. The verification
of md5 checksums and GPG signatures is performed automatically for you.

All packages are signed by Mandriva for security. You can obtain the
GPG public key of the Mandriva Security Team by executing:

gpg --recv-keys --keyserver pgp.mit.edu 0x22458A98

You can view other update advisories for Mandriva Linux at:

http://www.mandriva.com/security/advisories

If you want to report vulnerabilities, please contact

security_(at)_mandriva.com
_______________________________________________________________________

Type Bits/KeyID Date User ID
pub 1024D/22458A98 2000-07-10 Mandriva Security Team
<security*mandriva.com>
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2.2 (GNU/Linux)

iD8DBQFEHw0bmqjQ0CJFipgRAj3PAJ9MKwFvrdwhll7obp6h0tDiBoi36ACfVijD
7KS+I5Xzsv7M2NAxP62ukrM=
=RwN4
-----END PGP SIGNATURE-----

[ reply ]


 

Privacy Statement
Copyright 2010, SecurityFocus