BugTraq
[ GLSA 200604-07 ] Cacti: Multiple vulnerabilities in included ADOdb Apr 14 2006 08:33PM
Thierry Carrez (koon gentoo org)
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 200604-07
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: High
Title: Cacti: Multiple vulnerabilities in included ADOdb
Date: April 14, 2006
Bugs: #129284
ID: 200604-07

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities have been discovered in the ADOdb layer
included in Cacti, potentially resulting in the execution of arbitrary
code.

Background
==========

Cacti is a complete web-based frontend to rrdtool. ADOdb is a PHP-based
database abstraction layer which is included in Cacti.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 cacti < 0.8.6h_p20060108-r2 >= 0.8.6h_p20060108-r2

Description
===========

Several vulnerabilities have been identified in the copy of ADOdb
included in Cacti. Andreas Sandblad discovered a dynamic code
evaluation vulnerability (CVE-2006-0147) and a potential SQL injection
vulnerability (CVE-2006-0146). Andy Staudacher reported another SQL
injection vulnerability (CVE-2006-0410), and Gulftech Security
discovered multiple cross-site-scripting issues (CVE-2006-0806).

Impact
======

Remote attackers could trigger these vulnerabilities by sending
malicious queries to the Cacti web application, resulting in arbitrary
code execution, database compromise through arbitrary SQL execution,
and malicious HTML or JavaScript code injection.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All Cacti users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose
">=net-analyzer/cacti-0.8.6h_p20060108-r2"

References
==========

[ 1 ] CVE-2006-0146
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-0146
[ 2 ] CVE-2006-0147
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-0147
[ 3 ] CVE-2006-0410
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-0410
[ 4 ] CVE-2006-0806
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-0806

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-200604-07.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security (at) gentoo (dot) org [email concealed] or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2006 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.0

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2.2 (GNU/Linux)
Comment: Using GnuPG with Thunderbird - http://enigmail.mozdev.org

iD8DBQFEQAcUvcL1obalX08RAhJUAJ90KytDlBHyMPtjucd/U/lXJtzr9ACfYsMF
hqpRIGLCqmolyV0kbS9EGCA=
=cIat
-----END PGP SIGNATURE-----

[ reply ]


 

Privacy Statement
Copyright 2010, SecurityFocus