BugTraq
[ GLSA 200605-12 ] Quake 3 engine based games: Buffer Overflow May 10 2006 05:29AM
Sune Kloppenborg Jeppesen (jaervosz gentoo org)
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 200605-12
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: Quake 3 engine based games: Buffer Overflow
Date: May 10, 2006
Bugs: #132377
ID: 200605-12

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

The Quake 3 engine has a vulnerability that could be exploited to
execute arbitrary code.

Background
==========

Quake 3 is a multiplayer first person shooter.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 games-fps/quake3-bin < 1.32c >= 1.32c
2 games-fps/rtcw < 1.41b >= 1.41b
3 games-fps/enemy-territory < 2.60b >= 2.60b
-------------------------------------------------------------------
3 affected packages on all of their supported architectures.
-------------------------------------------------------------------

Description
===========

landser discovered a vulnerability within the "remapShader" command.
Due to a boundary handling error in "remapShader", there is a
possibility of a buffer overflow.

Impact
======

An attacker could set up a malicious game server and entice users to
connect to it, potentially resulting in the execution of arbitrary code
with the rights of the game user.

Workaround
==========

Do not connect to untrusted game servers.

Resolution
==========

All Quake 3 users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=games-fps/quake3-bin-1.32c"

All RTCW users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=games-fps/rtcw-1.41b"

All Enemy Territory users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=games-fps/enemy-territory-2.60b"

References
==========

[ 1 ] CVE-2006-2236
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-2236

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-200605-12.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security (at) gentoo (dot) org [email concealed] or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2006 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2.2 (GNU/Linux)

iD8DBQBEYXoszKC5hMHO6rkRAgSDAKCCGv8PzR5e2d9AdshcYWcYRcKsPACfXnm9
lNNU8YzO3e8mgSHZUmfpBsg=
=n8TC
-----END PGP SIGNATURE-----

[ reply ]


 

Privacy Statement
Copyright 2010, SecurityFocus