Security Advisory for Bugzilla 2.20.3, 2.22.1, and 2.23.3 Feb 03 2007 01:54AM
mkanat bugzilla org
Hash: SHA1


Bugzilla is a Web-based bug-tracking system, used by a large number of
software projects.

This advisory covers two security issues that have recently been
fixed in the Bugzilla code:

+ A possible cross-site scripting (XSS) vulnerability in Atom feeds
produced by Bugzilla.

+ Web server settings given by Bugzilla which provide security settings
to protect data files from access via the web are overridden by the
mod_perl startup script when running under mod_perl (development
snapshot only).

We strongly advise that 2.20.x users should upgrade to 2.20.4. 2.22
users, and users of 2.16.x or below, should upgrade to 2.22.2. Versions
2.18.x are not affected by either of these vulnerabilities.

Development snapshots of 2.23 before 2.23.4 are also vulnerable to all
of these issues. If you are using a development snapshot, you should
upgrade to 2.23.4, use CVS to update, or apply the patches from the
specific bugs listed below.

Vulnerability Details

Issue 1
- -------
Class: Cross-Site Scripting
Versions: 2.20.1 and above
Description: Bugzilla does not properly escape some fields in generated
Atom feeds, which leads to the potential for cross-site
scripting in feed readers that support javascript and
properly implement the Atom feed specification.
Reference: https://bugzilla.mozilla.org/show_bug.cgi?id=367674

Issue 2
- -------
Class: Database password disclosure
Versions: 2.23.3 only
Description: Bugzilla development snapshot version 2.23.3 introduced
the ability to run Bugzilla under mod_perl on Apache.
The mod_perl initialization script included with Bugzilla
defines a new <Directory> block in the Apache configuration
for the directory containing Bugzilla. This block fails to
include permission for .htaccess files to override file
access permissions. The .htaccess file shipped with
Bugzilla prohibits access by web browsers to read the
localconfig file, which contains the username and password
for connecting to the database server.
If you are not running Bugzilla under mod_perl, then this
does not affect you.
Reference: https://bugzilla.mozilla.org/show_bug.cgi?id=367071

Vulnerability Solutions

The fixes for all of the security bugs mentioned in this advisory are
included in the 2.20.4, 2.22.2, and 2.23.4 releases. Upgrading to these
releases will protect installations from possible exploits of these

Full release downloads, patches to upgrade Bugzilla from previous
versions, and CVS upgrade instructions are available at:


Specific patches for each of the individual issues can be found on the
corresponding bug reports for each issue, at the URL given in the
reference for that issue in the list above.


The Bugzilla team wish to thank the following people for their
assistance in locating, advising us of, and assisting us to fix these

Frédéric Buclin
Dave Miller
Olav Vitters
Max Kanat-Alexander

General information about the Bugzilla bug-tracking system can be found


Comments and follow-ups can be directed to the mozilla.support.bugzilla
newsgroup or the support-bugzilla mailing list.
http://www.bugzilla.org/support/ has directions for accessing these
Version: GnuPG v1.4.6 (GNU/Linux)


[ reply ]


Privacy Statement
Copyright 2010, SecurityFocus