BugTraq
[ GLSA 200908-07 ] Perl Compress::Raw modules: Denial of Service Aug 18 2009 09:37PM
Alex Legler (a3li gentoo org)
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 200908-07
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: Perl Compress::Raw modules: Denial of Service
Date: August 18, 2009
Bugs: #273141, #281955
ID: 200908-07

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

An off-by-one error in Compress::Raw::Zlib and Compress::Raw::Bzip2
might lead to a Denial of Service.

Background
==========

Compress::Raw::Zlib and Compress::Raw::Bzip2 are Perl low-level
interfaces to the zlib and bzip2 compression libraries.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 perl-core/Compress-Raw-Zlib < 2.020 >= 2.020
2 perl-core/Compress-Raw-Bzip2 < 2.020 >= 2.020
-------------------------------------------------------------------
2 affected packages on all of their supported architectures.
-------------------------------------------------------------------

Description
===========

Leo Bergolth reported an off-by-one error in the inflate() function in
Zlib.xs of Compress::Raw::Zlib, possibly leading to a heap-based buffer
overflow (CVE-2009-1391).

Paul Marquess discovered a similar vulnerability in the bzinflate()
function in Bzip2.xs of Compress::Raw::Bzip2 (CVE-2009-1884).

Impact
======

A remote attacker might entice a user or automated system (for instance
running SpamAssassin or AMaViS) to process specially crafted files,
possibly resulting in a Denial of Service condition.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All Compress::Raw::Zlib users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose
=perl-core/Compress-Raw-Zlib-2.020

All Compress::Raw::Bzip2 users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose
=perl-core/Compress-Raw-Bzip2-2.020

References
==========

[ 1 ] CVE-2009-1391
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2009-1391
[ 2 ] CVE-2009-1884
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2009-1884

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-200908-07.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security (at) gentoo (dot) org [email concealed] or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2009 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.11 (GNU/Linux)

iEYEARECAAYFAkqLHxUACgkQk+oqhfPAZGmDhgCZAR1FjZUxHh2X9MAxIpaX6D81
uIAAn01zKBRWsX8X/lihUXvuXmKiTAdS
=rW1/
-----END PGP SIGNATURE-----

[ reply ]


 

Privacy Statement
Copyright 2010, SecurityFocus