BugTraq
XSS in Oracle default fcgi-bin/echo Oct 08 2010 03:18AM
paul szabo sydney edu au
Many Oracle web server installations have a fcgi-bin/echo script
left over from default demo (google for inurl:fcgi-bin/echo). That
script seems vulnerable to XSS. (PoC exploit and explanation of
impact withheld now.)

I asked security (at) oracle (dot) com [email concealed] and they said that "... this issue has
been resolved in an earlier Critical Patch Update." I looked at some
recent CPU summaries, but did not notice anything relevant: maybe
their reply refers to the old http://www.kb.cert.org/vuls/id/717827 ?

Website owners please remove demo software from production servers,
e.g. as per Oracle recommendation
http://download.oracle.com/docs/cd/B14099_19/core.1012/b13999/checklist.
htm#BABIBCIC

Cheers, Paul

Paul Szabo psz (at) maths.usyd.edu (dot) au [email concealed] http://www.maths.usyd.edu.au/u/psz/
School of Mathematics and Statistics University of Sydney Australia

[ reply ]


 

Privacy Statement
Copyright 2010, SecurityFocus