BugTraq
[security bulletin] HPSBMU02746 SSRT100781 rev.1 - HP Data Protector Express, Remote Denial of Service (DoS), Execution of Arbitrary Code Mar 13 2012 02:47AM
security-alert hp com
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

SUPPORT COMMUNICATION - SECURITY BULLETIN

Document ID: c03229235
Version: 1

HPSBMU02746 SSRT100781 rev.1 - HP Data Protector Express, Remote Denial of Service (DoS), Execution of Arbitrary Code

NOTICE: The information in this Security Bulletin should be acted upon as soon as possible.

Release Date: 2012-03-12
Last Updated: 2012-03-12

------------------------------------------------------------------------
------

Potential Security Impact: Remote Denial of Service (DoS), execution of arbitrary code

Source: Hewlett-Packard Company, HP Software Security Response Team

VULNERABILITY SUMMARY
Potential security vulnerabilities have been identified with HP Data Protector Express (DPX) 5.0 and 6.0. The vulnerabilities could be exploited remotely to create a Denial of Service (DoS) or to execute arbitrary code.

References: CVE-2012-0121, ZDI-CAN-1392; CVE-2012-01222, ZDI-CAN-1393; CVE-2012-0123, ZDI-CAN-1498; and CVE-2012-0124

SUPPORTED SOFTWARE VERSIONS*: ONLY impacted versions are listed.
HP Data Protector Express (DPX) 5.0.00 prior to build 59287
HP Data Protector Express (DPX) 6.0.00 prior to build 11974

Note: DPX users can identify the build number by clicking on 'Help' and then 'About'.

BACKGROUND

CVSS 2.0 Base Metrics
===========================================================
Reference Base Vector Base Score
CVE-2012-0121 (AV:N/AC:L/Au:N/C:C/I:C/A:C) 10.0
CVE-2012-0122 (AV:N/AC:L/Au:N/C:C/I:C/A:C) 10.0
CVE-2012-0123 (AV:N/AC:L/Au:N/C:C/I:C/A:C) 10.0
CVE-2012-0124 (AV:N/AC:L/Au:N/C:C/I:C/A:C) 10.0
===========================================================
Information on CVSS is documented
in HP Customer Notice: HPSN-2008-002

The Hewlett-Packard Company thanks e6af8de8b1d4b2b6d5ba2610cbf9cd38 working with TippingPoint for reporting CVE-2012-0123 to security-alert (at) hp (dot) com [email concealed]
The Hewlett-Packard Company thanks Aaron Portnoy of TippingPoint for reporting CVE-2012-0121 and CVE-2012-0122 to security-alert (at) hp (dot) com [email concealed]
The Hewlett-Packard Company thanks Juan Vazquez along with BeyondSecurity.com for reporting CVE-2012-0124 to security-alert (at) hp (dot) com [email concealed]

RESOLUTION

HP has provided upgrades to resolve these vulnerabilities. For Installations Running Data Protector Express 6.0

Microsoft Windows, Linux (see Compatibility Matrix link below)
Install HP Data Protector Express 6.0.01 build 13958 or later, available here:
http://h20000.www2.hp.com/bizsupport/TechSupport/ProductList.jsp?prodSer
iesId=1144272

For Installations Running Data Protector Express 5.0

Microsoft Windows, Linux (see Compatibility Matrix link below)
Install HP Data Protector Express 5.0.01 build 70262 or later, available here:
http://h20000.www2.hp.com/bizsupport/TechSupport/ProductList.jsp?prodSer
iesId=1144272

The HP Data Protector Express Compatibility Matrix provides information about the operating systems, applications, and backup devices tested by HP to be compatible with Data Protector Express and Data Protector Express Basic. See http://h18006.www1.hp.com/products/storage/software/datapexp/pdf/DPXMatr
ix_1109.pdf

Note: For questions about upgrading Data Protector Express, contact HP Services and Support.

HISTORY
Version:1 (rev.1) 12 March 2012 Initial release
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.10 (GNU/Linux)

iEYEARECAAYFAk9etOEACgkQ4B86/C0qfVlpSwCfdUeJOCp+RNZiU6ayWyBG3qST
hRwAoKRu/WeO2sMekCxqdaI7IuW9717H
=+Y3r
-----END PGP SIGNATURE-----

[ reply ]


 

Privacy Statement
Copyright 2010, SecurityFocus