BugTraq
[ MDVSA-2012:158 ] gc Oct 03 2012 01:01PM
security mandriva com
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

_______________________________________________________________________

Mandriva Linux Security Advisory MDVSA-2012:158
http://www.mandriva.com/security/
_______________________________________________________________________

Package : gc
Date : October 3, 2012
Affected: 2011., Enterprise Server 5.0
_______________________________________________________________________

Problem Description:

A security issue was identified and fixed in gc:

Multiple integer overflows in the (1) GC_generic_malloc and (2) calloc
funtions in malloc.c, and the (3) GC_generic_malloc_ignore_off_page
function in mallocx.c in Boehm-Demers-Weiser GC (libgc) before 7.2 make
it easier for context-dependent attackers to perform memory-related
attacks such as buffer overflows via a large size value, which causes
less memory to be allocated than expected (CVE-2012-2673).

The updated packages have been patched to correct this issue.
_______________________________________________________________________

References:

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2012-2673
_______________________________________________________________________

Updated Packages:

Mandriva Linux 2011:
ff80b2641fc3764b7ed98eb6a8b7310a 2011/i586/libgc1-7.1-8.1-mdv2011.0.i586.rpm
85d77990548165fb44b9969ebaa37a08 2011/i586/libgc-devel-7.1-8.1-mdv2011.0.i586.rpm
9a40880c129be459fab7610510bb3dea 2011/i586/libgc-static-devel-7.1-8.1-mdv2011.0.i586.rpm
3433f6fce39c37469114ce2e40770570 2011/SRPMS/gc-7.1-8.1.src.rpm

Mandriva Linux 2011/X86_64:
ac0a695e6ba1d01c58db329ac275e029 2011/x86_64/lib64gc1-7.1-8.1-mdv2011.0.x86_64.rpm
2b73bed5897460c97e03a8bc4eb512c4 2011/x86_64/lib64gc-devel-7.1-8.1-mdv2011.0.x86_64.rpm
ed2ca7c3c40648a6074e0a5990c49efa 2011/x86_64/lib64gc-static-devel-7.1-8.1-mdv2011.0.x86_64.rpm
3433f6fce39c37469114ce2e40770570 2011/SRPMS/gc-7.1-8.1.src.rpm

Mandriva Enterprise Server 5:
4d2dc87cd0f10a438e98f38bf9f53d86 mes5/i586/libgc1-7.1-2.1mdvmes5.2.i586.rpm
fa03fc646070e70d995f3f09d0121754 mes5/i586/libgc-devel-7.1-2.1mdvmes5.2.i586.rpm
12278c7b66468f7d4bb8bbfbd3140e54 mes5/i586/libgc-static-devel-7.1-2.1mdvmes5.2.i586.rpm
04ee1a3f43fdc35db778f7173a78462a mes5/SRPMS/gc-7.1-2.1mdvmes5.2.src.rpm

Mandriva Enterprise Server 5/X86_64:
a0ba63a6646876564e4f67559213d785 mes5/x86_64/lib64gc1-7.1-2.1mdvmes5.2.x86_64.rpm
76159b94d17a53b8946e61e87c7a474a mes5/x86_64/lib64gc-devel-7.1-2.1mdvmes5.2.x86_64.rpm
5a9475c338a052ad9b6b6cd2a29e89ac mes5/x86_64/lib64gc-static-devel-7.1-2.1mdvmes5.2.x86_64.rpm
04ee1a3f43fdc35db778f7173a78462a mes5/SRPMS/gc-7.1-2.1mdvmes5.2.src.rpm
_______________________________________________________________________

To upgrade automatically use MandrivaUpdate or urpmi. The verification
of md5 checksums and GPG signatures is performed automatically for you.

All packages are signed by Mandriva for security. You can obtain the
GPG public key of the Mandriva Security Team by executing:

gpg --recv-keys --keyserver pgp.mit.edu 0x22458A98

You can view other update advisories for Mandriva Linux at:

http://www.mandriva.com/security/advisories

If you want to report vulnerabilities, please contact

security_(at)_mandriva.com
_______________________________________________________________________

Type Bits/KeyID Date User ID
pub 1024D/22458A98 2000-07-10 Mandriva Security Team
<security*mandriva.com>
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.11 (GNU/Linux)

iD8DBQFQbAoymqjQ0CJFipgRAp5iAJ9+8wuQOcpZc8uZ9/zugBXbRKTrNQCdGpNT
iRzFeOMHtQmRP29Avb246JY=
=+JfI
-----END PGP SIGNATURE-----

[ reply ]


 

Privacy Statement
Copyright 2010, SecurityFocus