BugTraq
CubeCart 4.x/5.x | Setup Re-installation Privilege Escalation Vulnerability Dec 24 2012 09:43AM
YGN Ethical Hacker Group (lists yehg net)
1. OVERVIEW

CubeCart 4.x and 5.x versions are vulnerable to Setup Re-installation
Privilege Escalation.

2. BACKGROUND

CubeCart is an "out of the box" ecommerce shopping cart software
solution which has been written to run on servers that have PHP &
MySQL support. With CubeCart you can quickly setup a powerful online
store which can be used to sell digital or tangible products to new
and existing customers all over the world.

3. VULNERABILITY DESCRIPTION

CubeCart 4.x and 5.x versions contain a flaw that does not remove
set-up installation directory or warn users of the existence of set-up
installation directory. This allows an attacker to re-install the
application, gain administrator access and do malicious things such as
uploading malicious shell script to compromise the application server.

4. VERSIONS AFFECTED

CubeCart 4.x and 5.x

5. Affected URL

N.A

6. SOLUTION/WORKAROUND

The vendor has chosen not to fix the issue.
Workaround is to remove setup directory after installation.

7. VENDOR

CubeCart Development Team
http://cubecart.com/

8. CREDIT

Aung Khant, http://yehg.net, YGN Ethical Hacker Group, Myanmar.

9. DISCLOSURE TIME-LINE

2012-03-24: Vulnerability Reported
2012-12-24: Vulnerability disclosed

10. REFERENCES

Original Advisory URL:
http://yehg.net/lab/pr0js/advisories/%5Bcubecart_4x5x%5D_setup_re-instal
l-priv-esclate
CubeCart Home Page: http://cubecart.com/

#yehg [2012-12-24]
---------------------------------
Best regards,
YGN Ethical Hacker Group
Yangon, Myanmar
http://yehg.net
Our Lab | http://yehg.net/lab
Our Directory | http://yehg.net/hwd

[ reply ]


 

Privacy Statement
Copyright 2010, SecurityFocus