BugTraq
[ MDVSA-2014:023 ] hplip Jan 24 2014 07:04PM
security mandriva com
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

_______________________________________________________________________

Mandriva Linux Security Advisory MDVSA-2014:023
http://www.mandriva.com/en/support/security/
_______________________________________________________________________

Package : hplip
Date : January 24, 2014
Affected: Business Server 1.0
_______________________________________________________________________

Problem Description:

Updated hplip packages fix security vulnerabilities:

It was discovered that the HPLIP Polkit daemon incorrectly handled
temporary files. A local attacker could possibly use this issue to
overwrite arbitrary files (CVE-2013-6402).

It was discovered that HPLIP contained an upgrade tool that would
download code in an unsafe fashion. If a remote attacker were able
to perform a man-in-the-middle attack, this flaw could be exploited
to execute arbitrary code (CVE-2013-6427).
_______________________________________________________________________

References:

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2013-6402
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2013-6427
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=725876
_______________________________________________________________________

Updated Packages:

Mandriva Business Server 1/X86_64:
adc12c9248b6f2aef16d531f7e50ce41 mbs1/x86_64/hplip-3.12.4-1.3.mbs1.x86_64.rpm
e124ee062c8d494e9dfb3fca497c9eed mbs1/x86_64/hplip-doc-3.12.4-1.3.mbs1.x86_64.rpm
8473fa2dc4383384fe473901ccd22447 mbs1/x86_64/hplip-hpijs-3.12.4-1.3.mbs1.x86_64.rpm
da5b7c37451bc067f279fec666b45666 mbs1/x86_64/hplip-hpijs-ppds-3.12.4-1.3.mbs1.x86_64.rpm
8494b5a958e0660dcfdd878be5e0c4d6 mbs1/x86_64/hplip-model-data-3.12.4-1.3.mbs1.x86_64.rpm
5f3206efa244ac3a49e8738f3b115936 mbs1/x86_64/lib64hpip0-3.12.4-1.3.mbs1.x86_64.rpm
a8b8517ec195e3d6626a6d3bf537d429 mbs1/x86_64/lib64hpip0-devel-3.12.4-1.3.mbs1.x86_64.rpm
e808dcb068262a1450f4b2e49924c8a1 mbs1/x86_64/lib64sane-hpaio1-3.12.4-1.3.mbs1.x86_64.rpm
68139aac8cebae63bc0ad47490b6b83e mbs1/SRPMS/hplip-3.12.4-1.3.mbs1.src.rpm
_______________________________________________________________________

To upgrade automatically use MandrivaUpdate or urpmi. The verification
of md5 checksums and GPG signatures is performed automatically for you.

All packages are signed by Mandriva for security. You can obtain the
GPG public key of the Mandriva Security Team by executing:

gpg --recv-keys --keyserver pgp.mit.edu 0x22458A98

You can view other update advisories for Mandriva Linux at:

http://www.mandriva.com/en/support/security/advisories/

If you want to report vulnerabilities, please contact

security_(at)_mandriva.com
_______________________________________________________________________

Type Bits/KeyID Date User ID
pub 1024D/22458A98 2000-07-10 Mandriva Security Team
<security*mandriva.com>
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.12 (GNU/Linux)

iD8DBQFS4o8AmqjQ0CJFipgRAt/kAJ9K1QKlPy2r/lF/DgBDldjVIFIksQCcCusG
T9Gl/6j4lvhc4YQDWjSuLUM=
=Jigf
-----END PGP SIGNATURE-----

[ reply ]


 

Privacy Statement
Copyright 2010, SecurityFocus