BugTraq
CVE-2014-4326 Remote command execution in Logstash zabbix and nagios_nsca outputs. Jul 18 2014 05:04PM
Jordan Sissel (jordan sissel elasticsearch com)
Vendor: Elasticsearch
Product: Logstash
CVE: CVE-2014-4326
Affected versions: Logstash 1.0.14 through 1.4.1

Recommendations: All affected users should upgrade to Logstash 1.4.2.
We also provide patch instructions for Logstash 1.3.x at the bottom of
this note.

The vulnerability impacts deployments that use either the zabbix or
the nagios_nsca outputs. In these cases, an attacker with an ability
to send crafted events to any source of data for Logstash could
execute operating system commands with the permissions of the Logstash
process.

Deployments that do not use the zabbix or the nagios_nsca outputs are
not vulnerable and do not need to upgrade for this reason.

We would like to thank Jan Karwowski and Danila Borisiuk for reporting
the issue and working with us on the resolution.

Related links:

http://www.elasticsearch.org/blog/logstash-1-4-2/

Logstash 1.3.x patch instructions:

mkdir -p /tmp/logstash-patch/logstash/
outputs
wget -O /tmp/logstash-patch/logstash/outputs/zabbix.rb
https://github.com/elasticsearch/logstash-contrib/raw/v1.4.2/lib/logstas
h/outputs/zabbix.rb
wget -O /tmp/logstash-patch/logstash/outputs/nagios_nsca.rb
https://github.com/elasticsearch/logstash/raw/v1.4.2/lib/logstash/output
s/nagios_nsca.rb
jar uf logstash-1.3.3-flatjar.jar -C /tmp/logstash-patch/
logstash/outputs/zabbix.rb -C /tmp/logstash-patch/
logstash/outputs/nagios_nsca.rb

SHA256 of the two files fetched for this patch process:

9f86c2ba1940d507f54fffee209bbdcf43a658973c99c2f8bded1e36b31c21d7
./logstash/outputs/zabbix.rb

2982178fabbf3de5d40e9bbfb1320d3466338371611d77e22804d21caa8e135f
./logstash/outputs/nagios_nsca.rb

[ reply ]


 

Privacy Statement
Copyright 2010, SecurityFocus