BugTraq
ESA-2014-055: EMC Network Configuration Manager (NCM) Report Advisor Session Fixation Vulnerability Aug 08 2014 12:39PM
Security Alert (Security_Alert emc com)

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

ESA-2014-055: EMC Network Configuration Manager (NCM) Report Advisor Session Fixation Vulnerability

EMC Identifier: ESA-2014-055

CVE Identifier: CVE-2014-2509

Severity Rating: CVSS v2 Base Score: 6.9 (AV:A/AC:M/Au:N/C:C/I:P/A:P)

Affected products:

? EMC NCM Report Advisor 9.2.2a and earlier

Summary: EMC NCM Report Advisor is vulnerable to session fixation vulnerability that can be potentially exploited by malicious users to compromise the affected system.

Details:

The Report Advisor component in EMC NCM is vulnerable to session fixation vulnerability where the session cookie is set prior to authentication. An attacker can potentially exploit this vulnerability by stealing a NCM user?s session and accessing the application with the NCM user?s privileges.

Resolution:

The vulnerable Report Advisor (RA) component has been removed from EMC NCM version 9.3 installation package by default.

Customers who are using RA version 9.2.2.a and earlier (including the integration with NCM 9.3) are advised to follow one or more upgrade paths below.

Scenario 1: Customers who have deployed Report Advisor (RA) 9.2.2a with NCM 9.3 on separate hosts are recommended to upgrade by following the steps below:

? Step 1: Upgrade NCM 9.3 Application/Combination server to NCM 9.3 Patch 1

? Step 2: Upgrade RA 9.2.2a to RA 9.2.2a Patch 4

NOTE: RA 9.2.2a Patch 4 is not compatible with NCM 9.3 *without* Patch 1 (and above) installed. NCM 9.3 Patch 1 is available for download on https://support.emc.com.

Scenario 2: Customers who have deployed Report Advisor (RA) 9.2.2a with NCM 9.3 on the same host are recommended to upgrade by following the steps below:

? Upgrade NCM 9.3 Application/Combination server to NCM 9.3 Patch 1

Scenario 3: Customers who have deployed Report Advisor (RA) 9.2.2a with NCM 9.2.2a are recommended to upgrade by following the steps below:

? Upgrade RA and Application/Combination server to 9.2.2a Patch 4 simultaneously.

Patch Installation Table

NCM version 9.3.0.x NCM version 9.2.2.a.x

Local Report Advisor 9.2.2.a 9.3.0 Patch 1 Only 9.2.2.a Patch 4

Remote Report Advisor 9.2.2a 9.3.0. Patch 1 for AS/Combo Server & 9.2.2a Patch 4 for AS/Combo Server &

9.2.2A Patch 4 for Report Advisor Server 9.2.2a Patch 4 for Report Advisor Server

EMC recommends all customers using RA upgrade to the above versions listed at the earliest opportunity or uninstall RA alone, if not used.

Link to remedies:

Customers can download the software from https://support.emc.com/downloads/6259_Smarts-Network-Configuration-Mana
ger

Read and use the information in this EMC Security Advisory to assist in avoiding any situation that might arise from the problems described herein. If you have any questions regarding this product alert, contact EMC Software Technical Support at 1-877-534-2867.

For an explanation of Severity Ratings, refer to EMC Knowledgebase solution emc218831. EMC recommends all customers take into account both the base score and any relevant temporal and environmental scores which may impact the potential severity associated with particular security vulnerability.

EMC Corporation distributes EMC Security Advisories, in order to bring to the attention of users of the affected EMC products, important security information. EMC recommends that all users determine the applicability of this information to their individual situations and take appropriate action. The information set forth herein is provided "as is" without warranty of any kind. EMC disclaims all warranties, either express or implied, including the warranties of merchantability, fitness for a particular purpose, title and non-infringement. In no event, shall EMC or its suppliers, be liable for any damages whatsoever including direct, indirect, incidental, consequential, loss of business profits or special damages, even if EMC or its suppliers have been advised of the possibility of such damages. Some states do not allow the exclusion or limitation of liability for consequential or incidental damages, so the foregoing limitation may not apply.

EMC Product Security Response Center

security_alert (at) emc (dot) com [email concealed]

http://www.emc.com/products/security/product-security-response-center.ht
m

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.13 (Cygwin)

iEYEARECAAYFAlPkw/UACgkQtjd2rKp+ALzjrQCgtAmCOdwQ7dv0xwc+VVKnY5oI
8aUAn1GNQvTR4pFvetYX8bY3YoGWnCze
=7QVj
-----END PGP SIGNATURE-----

[ reply ]


 

Privacy Statement
Copyright 2010, SecurityFocus