BugTraq
ESA-2014-059: EMC Documentum Multiple Cross-Site Scripting Vulnerabilities Aug 18 2014 09:12PM
Security Alert (Security_Alert emc com)

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

ESA-2014-059: EMC Documentum Multiple Cross-Site Scripting Vulnerabilities

EMC Identifier: ESA-2014-059

CVE Identifier: CVE-2014-2511

Severity Rating: CVSS v2 Base Score: 7.5 (AV:N/AC:L/Au:N/C:P/I:P/A:P)

Affected products:

? EMC WebTop 6.7 SP1, 6.7 SP2

? EMC Documentum Administrator 6.7 SP1, 6.7 SP2, 7.0, 7.1.

? EMC Records Client 6.7 SP1, 6.7 SP2

? EMC Digital Assets Manager 6.5SP5, 6.5SP6

? EMC Web Publishers 6.5SP6, 6.5SP7

? EMC Task Space 6.7SP1, 6.7SP2

? EMC Engineering Plant Facilities Management Solution for Documentum 1.7SP1

? EMC Documentum Capital Projects 1.8

? EMC Documentum Capital Projects 1.9

Summary:

EMC Documentum WebTop based products contain fixes for multiple cross-site scripting vulnerabilities that could potentially be exploited by malicious users to compromise the affected system.

Details:

EMC Documentum WebTop based products contain fixes for multiple cross-scripting vulnerabilities that could potentially be exploited by malicious users to inject arbitrary script via some query string parameters. This may lead to execution of malicious html requests or scripts in the context of an authenticated user. These issues are caused due to the vulnerable parameters ?startat? and ?entryId?.

Resolution:

The following releases contain the resolution to these issues:

? EMC Documentum Administrator:

o 6.7 SP1 P28 or later

o 6.7 SP2 P14 or later

o 7.0 P15 or later

o 7.1 P06 or later

? EMC Documentum WebTop:

o 6.7 SP1 P28 or later

o 6.7 SP2 P14 or later

? EMC Records Client

o 6.7 SP1 P28 or later

o 6.7 SP2 P15 or later

? EMC Digital Assets Manager

o 6.5 SP5 P28 or later

o 6.5 SP6 P14 or later

? EMC Web Publishers

o 6.5 SP6 P28 or later

o 6.5 SP7 P14 or later

? EMC Task Space

o 6.7 SP1 P28 or later

o 6.7 SP2 P14 or later

? EMC Engineering Plant Facilities Management Solution for Documentum

o 1.7 SP1 P13 or later

? EMC Documentum Capital Projects

o 1.8 P11 or later

o 1.9 P01 or later

EMC recommends all customers upgrade to the fixed versions listed above at the earliest opportunity.

Link to remedies:

Customers can download the software using the links given below for respective products:

EMC Documentum Administrator 6.7 SP1:

https://emc.subscribenet.com/control/dctm/download?element=3887141

EMC Documentum Administrator 6.7 SP2:

https://emc.subscribenet.com/control/dctm/download?element=4541681

EMC Documentum Administrator 7.0:

https://emc.subscribenet.com/control/dctm/download?element=4787271

EMC Documentum Administrator 7.1:

https://emc.subscribenet.com/control/dctm/download?element=5096401

EMC Webtop 6.7SP1:

https://emc.subscribenet.com/control/dctm/download?element=3887191

EMC Webtop 6.7SP2:

https://emc.subscribenet.com/control/dctm/download?element=4544381

EMC Records Client 6.7SP1:

Webtop 6.7SP1 patch (https://emc.subscribenet.com/control/dctm/download?element=3887191) needs to be applied as per the instructions in Records client readme (https://emc.subscribenet.com/control/dctm/download?element=3887361 ).

EMC Records Client 6.7SP2:

Webtop 6.7SP2 patch (https://emc.subscribenet.com/control/dctm/download?element=4544381) needs to be applied as per the instructions in Records client readme (https://emc.subscribenet.com/control/dctm/download?element=4544641 )

EMC Digital Assets Manager 6.5 SP5

https://emc.subscribenet.com/control/dctm/download?element=3888781

EMC Digital Assets Manager 6.5 SP6

https://emc.subscribenet.com/control/dctm/download?element=4772311

EMC Web Publishers 6.5 SP6

https://emc.subscribenet.com/control/dctm/download?element=4059311

EMC Web Publishers 6.5 SP7

https://emc.subscribenet.com/control/dctm/download?element=4772271

EMC Task Space 6.7 SP1

https://emc.subscribenet.com/control/dctm/download?element=3887341

EMC Task Space 6.7 SP2

https://emc.subscribenet.com/control/dctm/download?element=4544451

EMC Engineering Plant Facilities Management Solution for Documentum 1.7 SP1

https://emc.subscribenet.com/control/dctm/download?element=4448871

EMC Capital Projects 1.8

https://emc.subscribenet.com/control/dctm/download?element=4928521

EMC Capital Projects 1.9

https://emc.subscribenet.com/control/dctm/download?element=5350311

Credits: EMC would like to thank Lukasz Plonka (Lukasz.Plonka (at) ingservicespolska (dot) pl [email concealed]) for reporting this issue.

Read and use the information in this EMC Security Advisory to assist in avoiding any situation that might arise from the problems described herein. If you have any questions regarding this product alert, contact EMC Software Technical Support at 1-877-534-2867.

For an explanation of Severity Ratings, refer to EMC Knowledgebase solution emc218831. EMC recommends all customers take into account both the base score and any relevant temporal and environmental scores which may impact the potential severity associated with particular security vulnerability.

EMC Corporation distributes EMC Security Advisories, in order to bring to the attention of users of the affected EMC products, important security information. EMC recommends that all users determine the applicability of this information to their individual situations and take appropriate action. The information set forth herein is provided "as is" without warranty of any kind. EMC disclaims all warranties, either express or implied, including the warranties of merchantability, fitness for a particular purpose, title and non-infringement. In no event, shall EMC or its suppliers, be liable for any damages whatsoever including direct, indirect, incidental, consequential, loss of business profits or special damages, even if EMC or its suppliers have been advised of the possibility of such damages. Some states do not allow the exclusion or limitation of liability for consequential or incidental damages, so the foregoing limitation may not apply.

EMC Product Security Response Center

security_alert (at) emc (dot) com [email concealed]

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.13 (Cygwin)

iEYEARECAAYFAlPyatkACgkQtjd2rKp+ALzpbACgou9ZVq8cEvNbas5+2FV/eYo+
GAUAoJpFeqoRvCZ6x5GS/QJkBoebh+zW
=WJpP
-----END PGP SIGNATURE-----

[ reply ]


 

Privacy Statement
Copyright 2010, SecurityFocus