BugTraq
January 2016 - Bamboo - Critical Security Advisory Jan 22 2016 12:00AM
David Black (dblack atlassian com)
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA512

Note: the current version of this advisory can be found at
https://confluence.atlassian.com/x/VzlZLw .

CVE IDs:
* CVE-2014-9757 - Deserialisation in Smack.
* CVE-2015-8360 - Deserialisation in Bamboo.
* CVE-2015-8361 - Missing authentication checks in exposed services.

Summary:
This advisory discloses multiple critical severity security
vulnerabilities of which the earliest vulnerability was introduced in
version 2.3.1 of Bamboo. Versions of Bamboo starting with 2.3.1 before
5.9.9 (the fixed version for 5.9.x) are vulnerable.

Atlassian Cloud instances have already been upgraded to a version of
Bamboo which does not have the issue described on this page.

Customers who have upgraded Bamboo to version 5.9.9 or version 5.10.0
are not affected.

Customers who have downloaded and installed Bamboo >= 2.3.1 less than
5.9.9 (the fixed version for 5.9.x)

Please upgrade your Bamboo installations immediately to fix this vulnerability.

Deserialisation Through Smack Resulting in Remote Code Execution
Vulnerability (CVE-2014-9757)
Severity:
Atlassian rates the severity level of this vulnerability as critical,
according to the scale published in our Atlassian severity levels. The
scale allows us to rank a severity as critical, high, moderate, or
low.
This is an independent assessment and you should evaluate its
applicability to your own IT environment.

Description:
Bamboo used an old version of the Smack XMPP library that deserialises
messages received from XMPP. Attackers can use this vulnerability to
execute Java code of their choice on systems that have a vulnerable
version of Bamboo if a XMPP connection has been configured. To exploit
this issue, Bamboo attackers need to be able to modify XMPP messages
destined to Bamboo from a configured XMPP server.

All versions of Bamboo from 2.4 before 5.9.9 (the fixed version for
5.9.x) are affected by this vulnerability. This issue can be tracked
here: https://jira.atlassian.com/browse/BAM-17099

Deserialisation Resulting in Remote Code Execution Vulnerability (CVE-2015-8360)
Severity:
Atlassian rates the severity level of this vulnerability as critical,
according to the scale published in our Atlassian severity levels. The
scale allows us to rank a severity as critical, high, moderate, or
low.
This is an independent assessment and you should evaluate its
applicability to your own IT environment.

Description
Bamboo had a resource that deserialised arbitrary user input without
restriction. Attackers can use this vulnerability to execute Java code
of their choice on systems that have a vulnerable version of Bamboo.
To exploit this issue, attackers need to be able to access the Bamboo
JMS port (port 54663 by default).

All versions of Bamboo from 2.3.1 before 5.9.9 (the fixed version for
5.9.x) are affected by this vulnerability. This issue can be tracked
here: https://jira.atlassian.com/browse/BAM-17101

Services exposed without authentication Vulnerability (CVE-2015-8361)
Severity:
Atlassian rates the severity level of this vulnerability as critical,
according to the scale published in our Atlassian severity levels. The
scale allows us to rank a severity as critical, high, moderate, or
low.
This is an independent assessment and you should evaluate its
applicability to your own IT environment.

Description:
Bamboo exposed services without first performing authentication
checks. Attackers can use this vulnerability to extract confidential
information from Bamboo, modify certain settings and manage build
agents. To exploit this issue, attackers need to be able to access the
Bamboo JMS port.

All versions of Bamboo from 2.4 before 5.9.9 (the fixed version for
5.9.x) are affected by this vulnerability. This issue can be tracked
here: https://jira.atlassian.com/browse/BAM-17102

Fix:
We have taken the follow steps to address these issues:
1. Released Bamboo version 5.10.0 that contains fixes for these issues.
2. Released Bamboo version 5.9.9 that contains fixes for this issues.

Remediation:
Upgrade Bamboo to version 5.9.9 or higher.

If you are running Bamboo 5.9.x and cannot upgrade to bamboo 5.10.x,
then upgrade to version 5.9.9.

For a full description of the latest version of Bamboo, see the
release notes found at
https://confluence.atlassian.com/display/BAMBOO/Bamboo+releases.
You can download the latest version of Bamboo from the download centre
found at https://www.atlassian.com/software/bamboo/download.

Support:
If you have questions or concerns regarding this advisory, please
raise a support request at https://support.atlassian.com/ .

- --
David Black / Security Engineer.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1

iQIcBAEBCgAGBQJWoWoKAAoJECQgl6K8UnagCpsP/0aqA3pOZvOWiW9VrwL2cpmL
XoAqN5blfeMFwm+BANT7uPkP8agau609lR4TM7C8BPo0DQkAD83PWDrinlC5jZgl
XVuT7JA4x/i8HBwb3MinUTFDtz62os83GrAMRlxv7IOzrOtYy02AF+NIQvwRwzVB
+dsqY+AgbPZEqvNeVO+KeEvSMFcwQYnHgtnWeUBCO8FVaUXTBoP7J2v8HZSuXMPU
yTkDgHIp8k3kaOwye5WJeQf8eMYe6E2HwbuHMvbk/F4EIBjoHqyIpGiI7b0XybcY
nu3A8osCYJo+H7c7j4vgPWDspiTt4EVRq/ngr7q0MosmVPbgmQ5dCja2lx0JEmjl
DafnOf87l594gPoSBrGVfIlT6KzdNHHAdYVliccZHRvubY1ALq2G1Laj4fKpTtQh
v2rojMVmVXbajrte94iB5AMBQum8/uPkEoVyfSG2yzMqJReMUi70PW0muM5qm/yb
NsEGXDQb0ie56CbsZk2hvgqr6fP7ikburKAISXiVJsM9Uo+jUluwBvzP9z8PuJRn
wzhjianT87wAYKQE60Dxdbwg0cCBf154ujMnDT7gRI+6vR59QU0Lih6f1nvi7zoc
T1+FVYoKBhMFCz8kkoD+bnGPu/GpJ88pfmnu+EAALe0lz3SUe5WSdETxIDl0h2cR
mcP+AOsQ6Y6nt3aZrUe/
=BVHU
-----END PGP SIGNATURE-----

[ reply ]


 

Privacy Statement
Copyright 2010, SecurityFocus