ManageEngine Eventlog Analyzer v4-v10 Privilege Esacalation Jan 29 2016 04:16PM
graphx sigaint org
# Exploit Title: ManageEngine Eventlog Analyzer Privilege Escalation
# Exploit Author: @GraphX
# Vendor Homepage:http://www.manageengine.com
# Version: 4.0 - 10

1. Description:
The manageengine eventlog analyzer fails to properly verify user
privileges when making changes via the userManagementForm.do. An
unprivileged user would be allowed to make changes to any account by
changing the USER_ID field to a number corresponding to another user.
Testing discovered that the default admin and guest accounts are 1 and 2.

Considering the recent similar vulnerabilities discovered in a more
current version of a similar product by ManageEngine, it is possible that
more versions of the software including current, are vulnerable. According
to the vendor this is fixed in version 10.8.

2) Proof of Concept

-login as an unprivileged user
-Use the following URL to change the admin password to "admin"

3 Solution:
Upgrade to 10.8

[ reply ]


Privacy Statement
Copyright 2010, SecurityFocus