BugTraq
[SECURITY] CVE-2017-5657: Apache Archiva CSRF vulnerability for REST endpoints May 19 2017 08:36PM
Martin (martin_s apache org)
CVE-2017-5657: Apache Archiva CSRF vulnerabilities for various REST endpoints

Severity: Important

Vendor:
The Apache Software Foundation

Versions Affected:
Archiva 2.0.0 - 2.2.1
The unsupported versions 1.x are also affected.

Several REST service endpoints of Apache Archiva are not protected against
Cross Site Request Forgery (CSRF) attacks. A malicious site opened in the same
browser as the archiva site, may send HTML response that performs arbitrary
actions on archiva services, with the same rights as the active archiva
session (e.g. adminstrator rights).

Mitigation:
All users are recommended to upgrade to Archiva 2.2.3 or higher,
where additional measures are taken to verify the origin of REST requests.

References:
http://archiva.apache.org/security.html#CVE-2017-5657

The newest Archiva version can be downloaded from:
http://archiva.apache.org/download.cgi

[ reply ]


 

Privacy Statement
Copyright 2010, SecurityFocus