[eVuln] TinyPHPForum Multiple Vulnerabilities Jan 05 2006 02:44AM
alex evuln com
New eVuln Advisory:
TinyPHPForum Multiple Vulnerabilities


Software: TinyPHPForum
Sowtware's Web Site: http://www.ralpharama.co.uk/tpf/
Versions: 3.6 and earlier
Critical Level: Moderate
Type: Multiple Vulnerabilities
Class: Remote
Status: Unpatched
Exploit: Available
Solution: Not Available
Discovered by: Aliaksandr Hartsuyeu (eVuln.com)
Published: 2006.01.05
eVuln ID: EV0014

1. Arbitrary script execution is possible when posting a link.
Condition: visitor needs to click this link

2. Registered users information disclosure.
users dir isn't hidden by .htaccess in default installation.

3. Directory Traversal is possible. (creating new user, new topic, viewing user's profile)

1. Arbitrary script execution. Example:

2. Users information disclosure:

3. Directory Traversal Example:
Registering new user.
username: http://host/tpf/profile.php?action=view&uname=../../username

No Patch available.

Original Advisory:

Discovered by: Aliaksandr Hartsuyeu (eVuln.com)

[ reply ]


Privacy Statement
Copyright 2010, SecurityFocus