Joomla/Mambo CMS Component SimpleBoard 1.1 XSS-Vulnerabilities Jun 01 2006 07:35PM
Yannick von Arx (yannick vonarx yanux ch)
Joomla/Mambo CMS Component SimpleBoard 1.1.0 Stable XSS-Vulnerabilities
=======================================================================

Release Date
------------
June 01, 2006

Vendor
-------
Two Shoes Mambo Factory
http://www.tsmf.net/

Version
-------
SimpleBoard 1.1.0 Stable (com_simpleboard) under Joomla CMS 1.0.8

Details
-------
Frontend (Public):
<forum_link> / <forum_title> / "post ne topic" / Name -> [XSS]

If the module "mod_simpleboard5" wich shows the latest posts (also
Username) is installed and aktivated for the frontpage (home), make
<script>history.back();</script> and no one can join the page again!

Backend (Admin Panel):
Components /Simpleboard Forum / Simpleboard Configuration / Basics ->
Title [XSS] (Community-Title)

Components /Simpleboard Forum / Simpleboard Administration / New ->
Name [XSS] (Forum-Title)

Components /Simpleboard Forum / Simpleboard Administration / New ->
Name [XSS] (Category-Title <- Choose "Top Level Category")

XSS example: <script>alert("XSS");</script>

Discovered by:
Yannick von Arx
yannick[dot]vonarx[at]yanux[dot]ch

[ reply ]


 

Privacy Statement
Copyright 2010, SecurityFocus