Re: Linux VNC evil client patch - BID 17978 Jun 24 2006 08:38AM
embyte madlab it
Moreover the vulnerability seems to be exploitable only by client RFB-3.8 [1] compliant, which means VNC4 (i.e. vnc4-4.1.1+X4.3.0 for linux). VNC3 for Linux and Windows are RFB-3.3.

This is because the new protocol version implements a different authentication handshake procedure. In fact attack doesn't work neither patching old clients, neither using them with the metasploit plugin realvnc_41_bypass.

That's all folks.

embyte

[1] Remote Frame Buffer protocol, http://realvnc.com/docs/rfbproto.pdf

[ reply ]


 

Privacy Statement
Copyright 2010, SecurityFocus