Back to list
LedgerSMB 1.0.0 and SQL-Ledger 2.6.18 and earler arbitrary code execution
Sep 12 2006 03:00AM
Chris Travers (chris metatrontech com)
A directory transversal issue was found in LedgerSMB 1.0.0 involving the
terminal variable. This vulnerability was inherited from the SQL-Ledger
codebase. Due to the fact that SQL-Ledger has a built-in text editor,
this issue could result in arbitrary code execution on the server. The
SQL-Ledger and LedgerSMB teams have both released patches to these
SQL-Ledger, all versions prior to 2.6.19.
Other SQL-Ledger derivatives should presume themselves vulnerable (we
have not checked).
SQL-Ledger 2.4.4-2.4.17 are particularly vulnerable due to CVE-2006-4244.
Authentication is required (only for LedgerSMB 1.0.0 and SQL-Ledger
2.4.3 and lower, or 2.6.18).
The "terminal" query variable is insufficiently checked in the login.pl
and admin.pl files for validity and can lead to directory transversal
and arbitrary code execution in SQL-Ledger (2.6.18 and earlier) and
LedgerSMB (1.0.0 only). In particular, an attacker could upload a file
called "login.pl" using these facilities. The attacher could then pass
a specially malformed url to the web server that would cause it to
execute the code. The form of the url might be:
In the course of our disclosure, we sent a notification to the developer
of SQL-Ledger who quickly patched his software.
All customers should upgrade to the newest versions of these packages at
their earliest convenience.
Credit for this disclosure should go to Chris Murtagh (a private
individual) and Richard Patterson of Quickhelp.
Metatron Technology Consulting
email;internet:chris (at) metatrontech (dot) com [email concealed]
[ reply ]
Copyright 2010, SecurityFocus