SAXON version 5.4 XSS Attack Vulnerability Oct 29 2007 03:55PM
securityresearch netvigilance com
netVigilance Security Advisory #54

SAXON version 5.4 XSS Attack Vulnerability

Description:

SAXON is a simple accessible online news publishing system for personal and small corporate site owners. Publish news, using configurable templates, on any .php page on your site. Publish news on a 'per author' basis. Edit and/or delete existing news items. Create multiple RSS news feeds automatically (RSS 0.9, RSS 2.0 and Atom). Post date news items for later public release. Multiple authors allowed. Ability to configure users as Standard or Administrators. Ability to add/delete users (Administrators only). Option to change any user password (Administrators only). Template creation/deletion/amendment interface. Online setup and configuration.

Successful exploitation requires PHP register_globals set to On and magic_quotes_gpc set to Off.

External References:

Mitre CVE: CVE-2007-4862

NVD NIST: CVE-2007-4862

OSVDB: Unassigned

BUGTRAQ/BID: Unassigned

Summary:

SAXON is a simple accessible online news publishing system for personal and small corporate site owners.

Security problems in the product allow attackers to conduct XSS attacks.

Advisory URL:

http://www.netvigilance.com/advisory0054

Release Date:

10/29/2007

CVSS Version 2 Metrics:

Base Metrics:

Exploitability Metrics:

Access Vector:

Network

Access Complexity:

Low

Authentication:

None

Impact Metrics:

Confidentiality Impact:

Partial

Integrity Impact:

Partial

Availability Impact:

Partial

Temporal Metrics:

Exploitability:

Functional

Remediation Level:

Official Fix

Report Confidence:

Confirmed

CVSS Version 2 Vectors:

Base Vector:

"AV:N/AC:L/Au:N/C:P/I:P/A:P"

Temporal Vector:

"E:F/RL:OF/RC:C"

CVSS Version 2 Scores:

Base Score:

7.5

Impact Subscore:

6.4

Exploitability Subscore:

10

Temporal Score:

6.2

SecureScout Testcase ID:

TC 17991

Vulnerable Systems:

SAXON version 5.4

Vulnerability Type:

XSS (Cross-Site Scripting) to force a web-site to display malicious contents to the target, by sending a specially crafted request to the web-site. The vulnerable web-site is not the target of attack but is used as a tool for the hacker in the attack of the victim.

Vendor:

Quirm

Vendor Status:

The Vendor has confirmed the problem and has release new version 5.41 that addresses the problem. New version of product was tested and we can confirm that all vulnerabilities were solved. For more information see vendor announcement. To download the latest version go to vendors product download area.

Workaround:

From netVigilance:

In the php.ini file set register_globals = Off.

From vendor:

Modify .htaccess file to include 'php_flag register_globals off' directive (this will work only for the Apache servers).

Example:

REQUEST:

http://[TARGET]/[PRODUCT DIRECTORY]/admin/menu.php?config[news_url]="><script>alert(document.cook
ies)</script>

REPLY:

will execute <script>alert(document.cookie)</script>

Credits:

Jesper Jurcenoks

Co-founder netVigilance, Inc

www.netvigilance.com

[ reply ]


 

Privacy Statement
Copyright 2010, SecurityFocus