Secure Shell
Having problems with X11 forwarding from F-Secure clients to OpenSSH servers Apr 15 2010 04:38PM
MERKEL, Brian (Brian MERKEL numonyx com)
I already posted this to comp.security.ssh, so if it's a duplicate, my
apologies.

I'm in the midst of migrating my environment (mostly Linux machines)
from F-Secure to OpenSSH, and I'm having some trouble getting the
X11forwarding working properly. Specifically, X11 forwarding from
F-Secure clients to OpenSSH servers. OpenSSH->OpenSSH works fine, as
does F-Secure->F-Secure. OpenSSH client with an F-Secure server works
as well. But when I try an F-Secure client connecting to an OpenSSH
server, my DISPLAY variable is not getting set.

on the OpenSSH system:
ssh -V output: OpenSSH_5.1p1, OpenSSL 0.9.8h 28 May 2008

in /etc/ssh/ssd_config:
X11Forwarding yes
AcceptEnv LANG LC_CTYPE LC_NUMERIC LC_TIME LC_COLLATE
LC_MONETARY LC_MESSAGES
AcceptEnv LC_PAPER LC_NAME LC_ADDRESS LC_TELEPHONE
LC_MEASUREMENT
AcceptEnv LC_IDENTIFICATION LC_ALL DISPLAY

in /etc/ssh/ssh_config:
ForwardX11 yes

on the F-Secure system:
ssh -V output: ssh: F-Secure SSH 3.3.2 (build 21) on
i686-pc-linux-gnu

in /etc/ssh2/sshd2_config:
AllowX11Forwarding yes
SettableEnvironmentVars
LANG,LC_ALL|COLLATE|CTYPE|MONETARY|NUMERIC|TIME),PATH,TERM,TZ,DISPLAY

in /etc/ssh2/ssh2_config:
ForwardX11 yes

Nothing in the local user's .ssh or .ssh2 configs overrides these
settings.

I know that Agent forwarding does not work between F-Secure and OpenSSH
due to a proprietary protocol used by F-Secure. Is this the case for
X11 forwarding as well? Am I missing something else?

Thanks!

Brian Merkel

[ reply ]


 

Privacy Statement
Copyright 2010, SecurityFocus