Secure Shell
ssh -g -L => bind: Address already in use, but it works anyway Jan 28 2011 04:38PM
Robert Dodier (robert infotility com) (1 replies)
Re: ssh -g -L => bind: Address already in use, but it works anyway Feb 07 2011 05:44PM
Robert Dodier (robert infotility com)
Hi, for the record, I was told to try -4 on the command line.
Indeed, that quiets the "Address already in use" message.
Maybe this is useful to someone else.

best,

Robert Dodier

On Fri, Jan 28, 2011 at 9:38 AM, Robert Dodier <robert (at) infotility (dot) com [email concealed]> wrote:
> Hi,
>
> I'm trying to use ssh for port forwarding.
> So far ssh -L has worked just fine for that purpose.
> Now I want to bind the port to all interfaces,
> so I tried ssh -g -L. The SSH session seems to launch
> successfully, and the port is forwarded as expected,
> and it is bound to all interfaces. However,
> I get an error message as the remote session is
> launched: "bind: Address already in use".
>
> I also tried ssh -b but ssh still complains "Address already in use".
>
> I have verified that that there actually isn't any
> other process using the port I want.
> I can't find any additional info in /var/log/messages
> or elsewhere in /var/log/.
>
> Since the port forwarding seems to work, I'm not
> too worried about it, but I'd like to understand what's
> going on. Any ideas?
>
> ssh on the client reports its version as
> "OpenSSH_3.9p1, OpenSSL 0.9.7a Feb 19 2003"
> and sshd on the server is openssh-server-4.5p1-6.fc7
> as reported by rpm.
>
> Thanks for your help,
>
> Robert Dodier

[ reply ]


 

Privacy Statement
Copyright 2010, SecurityFocus