WordPress 2kb Amazon Affiliates Store Plugin Multiple Cross Site Scripting Vulnerabilities

The 2kb Amazon Affiliates Store plugin for WordPress is prone to multiple cross-site scripting vulnerabilities because it fails to sufficiently sanitize user-supplied input.

An attacker may leverage these issues to execute arbitrary script code in the browser of an unsuspecting user in the context of the affected site. This may allow the attacker to steal cookie-based authentication credentials and to launch other attacks.

Versions prior to 2kb Amazon Affiliates Store Plugin 2.1.1 are vulnerable.


 

Privacy Statement
Copyright 2010, SecurityFocus