Solaris lpset -r Buffer Overflow Vulnerability

A vulnerability exists in the handling of the -r option to the lpset program, as included in Solaris 7 from Sun Microsystems. The -r option is undocumented. As such, its use in unknown. However, when supplied a well crafted buffer containing executable code, it is possible to execute arbitrary commands as root.


 

Privacy Statement
Copyright 2010, SecurityFocus