ncurses TERMCAP Buffer Overflow Vulnerability

The port of ncurses (a high-level terminal manipulation library) for FreeBSD (and quite likely other operating systems) included in earlier releases is vulnerable to a buffer overflow attack. If the TERMCAP environment variable contains more data than the maximum amount predefined in the library source, unchecked operations on it can result in the stack being overrun. The result is that any setuid programs linked to ncurses can be exploited via this vulnerability. Version 1.8.6 of ncurses (which shipped with FreeBSD 3.4-RELEASE is known to be vulnerable.

It has been confirmed that NetBSD is not vulnerable.


 

Privacy Statement
Copyright 2010, SecurityFocus