AIX frcactrl Insecure File Handling Vulnerability

A vulnerability exists in the frcactrl program, part of the Fast Response Cache Accelerator (FRCA) package, included with AIX 4.3 from IBM. The frcactrl program is shipped setuid root by IBM. If the FRCA kernel module is loaded, it is possible for local users to utilize the frcactrl program to modify files. In doing so, they can manipulate the configuration in such a way as to allow the modification, creation or overwriting of files as root. This in turn could lead to a compromise of the root account on the machine.


 

Privacy Statement
Copyright 2010, SecurityFocus