Linux knfsd Denial of Service Vulnerability

A denial of service exists in version of the Linux kernel, including versions of the 2.2.x kernel through 2.2.15pre20 and 2.3.99pre1. Due to inconsistencies in differentiating between signed and unsigned integers within the program, it becomes possible for a remote, unauthenticated user to cause the knfsd, and NFS service, to be unavailable.


 

Privacy Statement
Copyright 2010, SecurityFocus