Secure Locate LOCATE_PATH Validation Vulnerability

The LOCATE_PATH environment variable used by Secure Locate is not properly checked for validity. A malicious user could construct an invalid LOCATE_PATH variable which could cause an exploitable SEGV in slocate.

Secure Locate maintains an index of the entire filesystem, including files only visible by root. The slocate binary is setgid "slocate" so it can read this index. If slocate is properly exploited, the location of sensitive files could be revealed to an unprivileged local user.


 

Privacy Statement
Copyright 2010, SecurityFocus