L-Soft Listserv 1.8c and 1.8d Web Archives Long QUERY_STRING Buffer Overflow Vulnerability

A vulnerability exists in the web archive (wa, wa.exe) component of L-Soft's Listserv package. By supplying a long query string to the executable, composed of machine executable code, it is possible for an attacker to execute arbitrary code with the privileges of the Listserv daemon. This vulnerability affects version 1.8c and 1.8d of Listserv only; versions prior to 1.8c are not affected.

The vulnerability is similar to a previous vulnerability reported in the web archive portion of Listserv. Instead of passing a longer buffer as the value of a parameter in the string passed to the wa.exe cgi, a long buffer is passed as the actual query string: wa.exe?<long buffer>


 

Privacy Statement
Copyright 2010, SecurityFocus