Zope Unauthorized Role Access Vulnerability

Zope is a dynamic HTML management package, maintained by the Zope Project. A vulnerability exists that may allow users to gain elevated privileges.

The problem comes from the calculation of local roles. A problem in the computation climbing the wrong hierarchy of folders created a situation where local users would be given access to roles they were not members of or not authorized access in. This situation makes it possible for users with malicious intent to generate the circumstances necessary for the computation to grant unauthorized access, and exploit the issue to gain elevated privileges.


 

Privacy Statement
Copyright 2010, SecurityFocus