FreeBSD Linux Compatibility Mode Buffer Overflow Vulnerability

A vulnerability exists in the Linux compatibility portions of versions 3.x, 4.x and 5.x of FreeBSD. Versions of 5.0 released prior to July 23, 2000, 4.1 prior to July 29, 2000 and 3.5 prior to August 24, 2000, should be considered vulnerable. Releases after these dates are not vulnerable to this problem.

The Linux compatibility module implements what FreeBSD calls a "shadow" filesystem. This is overlayed on the regular filesystem hierarchy. This allows Linux binaries to see files in the shadow filesystem which can mask native files. If a user can create a file in the shadow filesystem which has a long name comprised of machine executable code, it is possible to overwrite values on the stack and execute the content of the buffer containing the filename. This is only the case if the Linux kernel module is loaded, or has been statically compiled in to the kernel. By default, it is not enabled.


 

Privacy Statement
Copyright 2010, SecurityFocus