FreeBSD Ports brouted Installation Permission Vulnerability

A vulnerability exists in the FreeBSD ports package for the brouted program. Vulnerable versions of brouted were available in the ports packages for 3.5-RELEASE and 4.1-RELEASE until August 22, 2000. Subsequent installations of the ports package are not vulnerable.

brouted is incorrectly installed with setgid kmem permissions. Versions of the port released prior to August 22, 2000 had buffer overflows in the command line argument handling. This could lead to local users being able to execute arbitrary code with GID kmem permissions. This could be used to elevate privilege to that of root by manipulating kernel memory.


 

Privacy Statement
Copyright 2010, SecurityFocus