SuSE Apache CGI Source Code Viewing Vulnerability

SuSE Linux versions 6.3 and 6.4 (previous versions may also be vulnerable) installs Apache web server (version 1.3.12 in version 6.4 of SuSE)

Apache configuration file /etc/httpd/httpd.conf contains an entry (Alias /cgi-bin-sdb/ /usr/local/httpd/cgi-bin/). Therefore, files in /cgi-bin/ can be accessed via URLs of the format http://target/cgi-bin-sdb as well. Because the path does not contain the string /cgi-bin/, improper permissions will be assigned, and the file will be sent to the client as opposed to being executed on the server.

This renders it possible to view the source code of CGI scripts stored in /cgi-bin/.


 

Privacy Statement
Copyright 2010, SecurityFocus