Libpng Graphics Library PNG_Set_Strip_Alpha Buffer Overflow Vulnerability

Bugtraq ID: 16626
Class: Boundary Condition Error
CVE: CVE-2006-0481
Remote: Yes
Local: Yes
Published: Feb 13 2006 12:00AM
Updated: Dec 15 2008 04:11PM
Credit: The vendor disclosed this vulnerability.
Vulnerable: Redhat Enterprise Linux WS 4
Redhat Enterprise Linux ES 4
Redhat Enterprise Linux AS 4
Redhat Desktop 4.0
libpng libpng3 1.2.7
+ Trustix Secure Enterprise Linux 2.0
libpng libpng3 1.2.6
libpng libpng 1.0.17
libpng libpng 1.0.16
Gentoo Linux
Not Vulnerable: libpng libpng3 1.2.8
+ Slackware Linux 10.2
+ Slackware Linux 10.1
+ Slackware Linux 10.1
+ Trustix Secure Linux 3.0.5
+ Trustix Secure Linux 3.0
+ Trustix Secure Linux 2.2


 

Privacy Statement
Copyright 2010, SecurityFocus