Flex Code Generation Buffer Overflow Vulnerability

Bugtraq ID: 16896
Class: Boundary Condition Error
CVE: CVE-2006-0459
Remote: Yes
Local: No
Published: Mar 01 2006 12:00AM
Updated: Jan 02 2007 05:52PM
Credit: Chris Moore discovered this issue.
Vulnerable: Ubuntu Ubuntu Linux 5.10 powerpc
Ubuntu Ubuntu Linux 5.10 i386
Ubuntu Ubuntu Linux 5.10 amd64
Ubuntu Ubuntu Linux 5.0 4 powerpc
Ubuntu Ubuntu Linux 5.0 4 i386
Ubuntu Ubuntu Linux 5.0 4 amd64
Ubuntu Ubuntu Linux 4.1 ppc
Ubuntu Ubuntu Linux 4.1 ia64
Ubuntu Ubuntu Linux 4.1 ia32
GNU Flex 2.5.32
GNU Flex 2.5.31
GNU Flex 2.5.30
Gentoo Linux
Debian Linux 3.1 sparc
Debian Linux 3.1 s/390
Debian Linux 3.1 ppc
Debian Linux 3.1 mipsel
Debian Linux 3.1 mips
Debian Linux 3.1 m68k
Debian Linux 3.1 ia-64
Debian Linux 3.1 ia-32
Debian Linux 3.1 hppa
Debian Linux 3.1 arm
Debian Linux 3.1 amd64
Debian Linux 3.1 alpha
Debian Linux 3.1
Not Vulnerable: GNU Flex 2.5.33


 

Privacy Statement
Copyright 2010, SecurityFocus