CGI Script Center News Update Password Changing Vulnerability

News Update is a shareware CGI program written in Perl that allows website operators to easily place headlines on their website. It is offered by CGI Script Center.

In version 1.1, it is possible for an anonymous attacker to remotely gain administrative access to the system. This is due to a bug in the implementation of admin password changing. The script fails to properly compare the password entered by the user to the old password (to verify that the administrator is who is really changing the password) and as a result anyone can change the administration password. Once administrative access is gained a malicious attacker can place arbitrary headlines on the victim website.


 

Privacy Statement
Copyright 2010, SecurityFocus