Mozilla Firefox JavaScript Handler Race Condition Memory Corruption Vulnerability

Solution:
The vendor has released updated versions of Firefox, Thunderbird, and SeaMonkey to address this issue. Please see the referenced advisories for more information.

Update: Reportedly, Firefox 1.5.0.7 and Seamonkey 1.0.5 may not actually fix this issue. Please contact the vendor for more information.


Mozilla Firefox 1.5.0.3

Mozilla Thunderbird 1.5.0.5

Netscape Browser 8.0

Mozilla Firefox 1.5.0.2

Mozilla Firefox 2.0 beta 1

Mozilla Firefox 1.5.0.1

Mozilla Firefox 1.5.0.5

Mozilla Firefox 1.5.0.7

Mozilla Thunderbird 1.5.0.4

Netscape Browser 8.1

Mozilla Thunderbird 1.5.0.2

Mozilla Firefox 1.5.0.6

Mozilla Firefox 0.10

Mozilla Thunderbird 0.7

Mozilla Thunderbird 0.7.2

Mozilla Thunderbird 0.7.3

Mozilla Firefox 0.8

Mozilla Thunderbird 0.8

Mozilla Firefox 0.9

Mozilla Thunderbird 0.9

Mozilla Firefox 0.9.1

Mozilla Firefox 0.9.2

Mozilla Firefox 0.9.3

Mozilla Firefox 1.0

Mozilla Firefox 1.0.1

Mozilla Thunderbird 1.0.1

Mozilla SeaMonkey 1.0.1

Mozilla SeaMonkey 1.0.2

Mozilla Firefox 1.0.2

Mozilla Thunderbird 1.0.2

Mozilla Firefox 1.0.3

Mozilla SeaMonkey 1.0.3

Mozilla Firefox 1.0.4

Mozilla Firefox 1.0.5

Mozilla Firefox 1.0.5

Mozilla Thunderbird 1.0.5

Mozilla Firefox 1.0.6

Mozilla Thunderbird 1.0.6

Mozilla Thunderbird 1.0.7

Mozilla Firefox 1.0.8

Mozilla Firefox 1.5

Mozilla Firefox 1.5 beta 2

Mozilla Thunderbird 1.5

Netscape Browser 8.0.3 .3

Netscape Browser 8.0.4

Netscape Browser 8.1.2


 

Privacy Statement
Copyright 2010, SecurityFocus