Drupal Pathauto Module Unspecified Cross-Site Scripting Vulnerability

Drupal Pathauto module is prone to a cross-site scripting vulnerability because it fails to properly sanitize user-supplied input.

An attacker may leverage this issue to have arbitrary script code execute in the browser of an unsuspecting user in the context of the affected site. This may help the attacker steal cookie-based authentication credentials and launch other attacks.

The following versions are affected:

- Drupal 4.6 with Pathauto (where the CVS $Id$ in pathauto_node.inc is older than 1.14.2.1)
- Drupal 4.7 with Pathauto (where the CVS $Id$ in pathauto_node.inc is older than 1.17.2.1).


 

Privacy Statement
Copyright 2010, SecurityFocus