PHP HTMLEntities HTMLSpecialChars Buffer Overflow Vulnerabilities

Bugtraq ID: 20879
Class: Boundary Condition Error
CVE: CVE-2006-5465
Remote: Yes
Local: No
Published: Nov 02 2006 12:00AM
Updated: Jun 30 2014 02:37PM
Credit: Stefan Esser is credited with the discovery of these vulnerabilities.
Vulnerable: Ubuntu Ubuntu Linux 5.10 sparc
Ubuntu Ubuntu Linux 5.10 powerpc
Ubuntu Ubuntu Linux 5.10 i386
Ubuntu Ubuntu Linux 5.10 amd64
Ubuntu Ubuntu Linux 6.10 sparc
Ubuntu Ubuntu Linux 6.10 powerpc
Ubuntu Ubuntu Linux 6.10 i386
Ubuntu Ubuntu Linux 6.10 amd64
Ubuntu Ubuntu Linux 6.06 LTS sparc
Ubuntu Ubuntu Linux 6.06 LTS powerpc
Ubuntu Ubuntu Linux 6.06 LTS i386
Ubuntu Ubuntu Linux 6.06 LTS amd64
Turbolinux Turbolinux Server 10.0 x86
Turbolinux Turbolinux Server 10.0
Turbolinux Turbolinux Server 8.0
Turbolinux Turbolinux 10 F...
TurboLinux Personal
TurboLinux Multimedia
Turbolinux Home
Turbolinux Appliance Server Workgroup Edition 1.0
Turbolinux Appliance Server Hosting Edition 1.0
Turbolinux Appliance Server 1.0 Workgroup Edition
Turbolinux Appliance Server 1.0 Hosting Edition
Turbolinux Appliance Server 2.0
Trustix Secure Linux 3.0
Trustix Secure Linux 2.2
Trustix Operating System Enterprise Server 2.0
Symantec Veritas NetBackup PureDisk Remote Office Edition 6.0
Slackware Linux 10.2
Slackware Linux 11.0
SGI ProPack 3.0 SP6
rPath rPath Linux 1
RedHat Stronghold for Enterprise Linux 0
RedHat Enterprise Linux WS 4
RedHat Enterprise Linux WS 3
RedHat Enterprise Linux WS 2.1 IA64
RedHat Enterprise Linux WS 2.1
RedHat Enterprise Linux ES 4
RedHat Enterprise Linux ES 3
RedHat Enterprise Linux ES 2.1 IA64
RedHat Enterprise Linux ES 2.1
RedHat Desktop 4.0
RedHat Desktop 3.0
RedHat Advanced Workstation for the Itanium Processor 2.1 IA64
RedHat Advanced Workstation for the Itanium Processor 2.1
Red Hat Enterprise Linux AS 4
Red Hat Enterprise Linux AS 3
Red Hat Enterprise Linux AS 2.1 IA64
Red Hat Enterprise Linux AS 2.1
PHP PHP 5.1.6
+ Ubuntu Ubuntu Linux 6.10 sparc
+ Ubuntu Ubuntu Linux 6.10 powerpc
+ Ubuntu Ubuntu Linux 6.10 i386
+ Ubuntu Ubuntu Linux 6.10 amd64
PHP PHP 5.1.5
PHP PHP 5.1.4
PHP PHP 5.1.3 -RC1
PHP PHP 5.1.3
PHP PHP 5.1.2
PHP PHP 5.1.1
PHP PHP 5.1
PHP PHP 5.0.5
PHP PHP 5.0.4
PHP PHP 5.0.3
PHP PHP 5.0.2
PHP PHP 5.0.1
PHP PHP 5.0 candidate 3
PHP PHP 5.0 candidate 2
PHP PHP 5.0 candidate 1
PHP PHP 5.0 .0
OpenPKG OpenPKG Stable
OpenPKG OpenPKG E1.0-Solid
OpenPKG OpenPKG Current
OpenPKG OpenPKG 2-Stable-20061018
Mandriva Linux Mandrake 2006.0 x86_64
Mandriva Linux Mandrake 2006.0
Mandriva Linux Mandrake 2007.0 x86_64
Mandriva Linux Mandrake 2007.0
MandrakeSoft Multi Network Firewall 2.0
MandrakeSoft Corporate Server 4.0 x86_64
MandrakeSoft Corporate Server 3.0 x86_64
MandrakeSoft Corporate Server 3.0
MandrakeSoft Corporate Server 4.0
Gentoo Linux
Debian Linux 3.1 sparc
Debian Linux 3.1 s/390
Debian Linux 3.1 ppc
Debian Linux 3.1 mipsel
Debian Linux 3.1 mips
Debian Linux 3.1 m68k
Debian Linux 3.1 ia-64
Debian Linux 3.1 ia-32
Debian Linux 3.1 hppa
Debian Linux 3.1 arm
Debian Linux 3.1 amd64
Debian Linux 3.1 alpha
Debian Linux 3.1
Cisco Unified Application Environment 2.3
Cisco Network Analysis Module 3.1 patch 2
Cisco Network Analysis Module 0
Cisco Hosting Solution Engine 1105 1.7.3
Cisco Hosting Solution Engine 1105 1.7.2
Cisco Hosting Solution Engine 1105 1.7.1
Cisco Hosting Solution Engine 1105 1.7
Cisco Hosting Solution Engine 1.3
Cisco Hosting Solution Engine 1.0
Cisco CiscoWorks Wireless LAN Solution Engine Express 0
Cisco CiscoWorks Wireless LAN Solution Engine (WLSE) 0
Cisco Catalyst 7600 3.1 (1a)WS-X6380-NAM
Cisco Catalyst 7600 3.1 (1a)WS-SVC-NAM-2
Cisco Catalyst 7600 3.1 (1a)WS-SVC-NAM-1
Cisco Catalyst 7600 2.2 (1a)WS-SVC-NAM-2
Cisco Catalyst 7600 2.2 (1a)WS-SVC-NAM-1
Cisco Catalyst 7600 2.1 (2)WS-X6380-NAM
Cisco Catalyst 6500 3.1 (1a)WS-X6380-NAM
Cisco Catalyst 6500 3.1 (1a)WS-SVC-NAM-2
Cisco Catalyst 6500 3.1 (1a)WS-SVC-NAM-1
Cisco Catalyst 6500 2.2 (1a)WS-SVC-NAM-2
Cisco Catalyst 6500 2.2 (1a)WS-SVC-NAM-1
Cisco Catalyst 6500 2.1 (2)WS-X6380-NAM
Cisco Catalyst 6000 3.1 (1a)WS-X6380-NAM
Cisco Catalyst 6000 3.1 (1a)WS-SVC-NAM-2
Cisco Catalyst 6000 3.1 (1a)WS-SVC-NAM-1
Cisco Catalyst 6000 2.2 (1a)WS-SVC-NAM-2
Cisco Catalyst 6000 2.2 (1a)WS-SVC-NAM-1
Cisco Catalyst 6000 2.1 (2)WS-X6380-NAM
Avaya S8710 R2.0.1
Avaya S8710 R2.0.0
Avaya S8710 CM 3.1
Avaya S8700 R2.0.1
Avaya S8700 R2.0.0
Avaya S8700 CM 3.1
Avaya S8500 R2.0.1
Avaya S8500 R2.0.0
Avaya S8500 CM 3.1
Avaya S8500 0
Avaya S8300 R2.0.1
Avaya S8300 R2.0.0
Avaya S8300 CM 3.1
Avaya S8300 0
Avaya Messaging Storage Server MM3.0
Avaya Messaging Storage Server 2.0
Avaya Messaging Storage Server 1.0
Avaya Messaging Storage Server
Avaya Message Networking
Avaya Intuity LX
Avaya Converged Communications Server 2.0
Apple Mac OS X Server 10.4.8
Apple Mac OS X Server 10.3.9
Apple Mac OS X 10.4.8
Apple Mac OS X 10.3.9
Not Vulnerable: Symantec Veritas NetBackup PureDisk Remote Office Edition 6.1
PHP PHP 5.2
+ Debian Linux 4.0 sparc
+ Debian Linux 4.0 s/390
+ Debian Linux 4.0 powerpc
+ Debian Linux 4.0 mipsel
+ Debian Linux 4.0 mips
+ Debian Linux 4.0 m68k
+ Debian Linux 4.0 ia-64
+ Debian Linux 4.0 ia-32
+ Debian Linux 4.0 hppa
+ Debian Linux 4.0 arm
+ Debian Linux 4.0 amd64
+ Debian Linux 4.0 alpha
+ Debian Linux 4.0
Cisco Unified Application Environment 2.4


 

Privacy Statement
Copyright 2010, SecurityFocus