GeoIP 'GeoIPUpdate.c' Directory Traversal Vulnerability

Bugtraq ID: 21959
Class: Input Validation Error
CVE: CVE-2007-0159
Remote: Yes
Local: No
Published: Jan 09 2007 12:00AM
Updated: May 20 2011 04:41PM
Credit: Dean Gaudet is credited with the discovery of this vulnerability.
Vulnerable: Ubuntu Ubuntu Linux 5.10 sparc
Ubuntu Ubuntu Linux 5.10 powerpc
Ubuntu Ubuntu Linux 5.10 i386
Ubuntu Ubuntu Linux 5.10 amd64
Ubuntu Ubuntu Linux 6.10 sparc
Ubuntu Ubuntu Linux 6.10 powerpc
Ubuntu Ubuntu Linux 6.10 i386
Ubuntu Ubuntu Linux 6.10 amd64
Ubuntu Ubuntu Linux 6.06 LTS sparc
Ubuntu Ubuntu Linux 6.06 LTS powerpc
Ubuntu Ubuntu Linux 6.06 LTS i386
Ubuntu Ubuntu Linux 6.06 LTS amd64
Maxmind geoip 1.3.10
MandrakeSoft Corporate Server 4.0 x86_64
MandrakeSoft Corporate Server 4.0
Not Vulnerable:


 

Privacy Statement
Copyright 2010, SecurityFocus